<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7"  xmlns:fb="https://www.facebook.com/2008/fbml"  xmlns:og="http://ogp.me/ns#" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8"  xmlns:fb="https://www.facebook.com/2008/fbml"  xmlns:og="http://ogp.me/ns#" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:og="http://ogp.me/ns#" lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=0.9, minimum-scale=0.9">
<meta name="description" content="Local news for Navarre, Navarre Beach and Gulf Breeze area in Northwest Florida panhandle." />
<title>Local narcotics trafficker arrested in Navarre | Navarre Press</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://navarrepress.com/xmlrpc.php" />
<link rel="stylesheet" type="text/css" media="print" href="https://navarrepress.com/wp-content/themes/Stylebook-NEW/print.css" />
<script type='text/javascript'>

var googletag = googletag || {};

googletag.cmd = googletag.cmd || [];

(function() {

var gads = document.createElement('script');

gads.async = true;

gads.type = 'text/javascript';

var useSSL = 'https:' == document.location.protocol;

gads.src = (useSSL ? 'https:' : 'http:') + 

'//www.googletagservices.com/tag/js/gpt.js';

var node = document.getElementsByTagName('script')[0];

node.parentNode.insertBefore(gads, node);

})();

</script>
<script type='text/javascript'>

googletag.cmd.push(function() {

googletag.defineSlot('/1371603/125x125_Box_Frontpage', [125, 125], 'div-gpt-ad-1415632547591-0').addService(googletag.pubads());

googletag.defineSlot('/1371603/BoxAd-Front', [300, 250], 'div-gpt-ad-1415637387971-0').addService(googletag.pubads());

googletag.defineSlot('/1371603/BoxAd-Front', [300, 250], 'div-gpt-ad-1415634730967-0').addService(googletag.pubads());

googletag.defineSlot('/1371603/BoxAd-Front', [300, 250], 'div-gpt-ad-1384382224685-0').addService(googletag.pubads());

googletag.defineSlot('/1371603/Front_Page_Image', [171, 285], 'div-gpt-ad-1384382224685-1').addService(googletag.pubads());

googletag.defineSlot('/1371603/Right_Skyscraper', [160, 600], 'div-gpt-ad-1384382224685-2').addService(googletag.pubads());

googletag.defineSlot('/1371603/Top-Banner', [728, 90], 'div-gpt-ad-1384382224685-3').addService(googletag.pubads());

googletag.pubads().enableSingleRequest();

googletag.enableServices();

});

</script>
<script type="text/javascript">

 var oa = document.createElement('script');

 oa.type = 'text/javascript'; oa.async = true;

 oa.src = '//navarrepress.api.oneall.com/socialize/library.js'

 var s = document.getElementsByTagName('script')[0];

 s.parentNode.insertBefore(oa, s)

</script>


<link rel="canonical" href="https://navarrepress.com/local/local-narcotics-trafficker-arrested-navarre/" />
<link rel="publisher" href="https://plus.google.com/+Navarrepress1" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/navarrepress.com\/","name":"Navarre Press","potentialAction":{"@type":"SearchAction","target":"https:\/\/navarrepress.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/navarrepress.com\/local\/local-narcotics-trafficker-arrested-navarre\/","sameAs":["https:\/\/www.facebook.com\/navarrepress","https:\/\/plus.google.com\/+Navarrepress1","https:\/\/twitter.com\/navarrepress"],"@id":"#organization","name":"Navarre Press","logo":""}</script>

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Navarre Press &raquo; Feed" href="https://navarrepress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Navarre Press &raquo; Comments Feed" href="https://navarrepress.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Navarre Press &raquo; iCal Feed" href="https://navarrepress.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Navarre Press &raquo; Local narcotics trafficker arrested in Navarre Comments Feed" href="https://navarrepress.com/local/local-narcotics-trafficker-arrested-navarre/feed/" />
<meta property="og:title" content="Local narcotics trafficker arrested in Navarre" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://navarrepress.com/local/local-narcotics-trafficker-arrested-navarre/" />
<meta property="og:site_name" content="Navarre Press" />
<meta property="og:image" content="https://navarrepress.com/wp-content/uploads/2017/11/Arrested-Troy-Duncan-1-300x188.jpg" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/navarrepress.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='tp-sidebar-login-css' href='https://navarrepress.com/wp-content/plugins/tt-sidebar-login-widget/assets/css/tt-sidebar-login.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://navarrepress.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='gabfire-widget-css-css' href='https://navarrepress.com/wp-content/plugins/gabfire-widget-pack/css/style.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='zoomify-css' href='https://navarrepress.com/wp-content/plugins/zoomifywp-express/_assets/css/zoomify_style.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='tooltip-css' href='https://navarrepress.com/wp-content/plugins/zoomifywp-express/_assets/css/tooltip.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-booklet-dark-css' href='https://navarrepress.com/wp-content/plugins/wp-booklet/themes/booklet/dark/booklet.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-booklet-light-css' href='https://navarrepress.com/wp-content/plugins/wp-booklet/themes/booklet/light/booklet.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css' href='https://navarrepress.com/wp-content/themes/Stylebook-NEW/framework/bootstrap/css/bootstrap.min.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-responsive-css' href='https://navarrepress.com/wp-content/themes/Stylebook-NEW/framework/bootstrap/css/bootstrap-responsive.min.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='https://navarrepress.com/wp-content/themes/Stylebook-NEW/framework/font-awesome/css/font-awesome.min.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='gabfire-style-css' href='https://navarrepress.com/wp-content/themes/Stylebook-NEW/style.css?ver=4.8.3' type='text/css' media='all' />
<script type='text/javascript' src='https://navarrepress.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-content/plugins/zoomifywp-express/_assets/js/ZoomifyImageViewerExpress-min.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-content/plugins/wp-booklet/assets/js/jquery.wpbooklet.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-content/plugins/wp-booklet/assets/js/jquery.wpbookletcarousel.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-content/plugins/wp-booklet/assets/js/jquery.wpbooklet-image-popup.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-content/plugins/wp-booklet/assets/js/jquery.wpbooklet-extended.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-content/themes/Stylebook-NEW/inc/js/jquery.cycle2.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-content/themes/Stylebook-NEW/inc/js/jquery.easing.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-content/themes/Stylebook-NEW/inc/js/jquery.contentcarousel.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-content/themes/Stylebook-NEW/framework/bootstrap/js/bootstrap.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-content/themes/Stylebook-NEW/inc/js/flowplayer/flowplayer.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-content/themes/Stylebook-NEW/inc/js/responsive-menu.js?ver=4.8.3'></script>
<link rel='https://api.w.org/' href='https://navarrepress.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://navarrepress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://navarrepress.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.8.3" />
<link rel='shortlink' href='https://navarrepress.com/?p=67512' />
<link rel="alternate" type="application/json+oembed" href="https://navarrepress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnavarrepress.com%2Flocal%2Flocal-narcotics-trafficker-arrested-navarre%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://navarrepress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnavarrepress.com%2Flocal%2Flocal-narcotics-trafficker-arrested-navarre%2F&#038;format=xml" />
<link rel="alternate" type="application/rss+xml" title="Navarre Press GeoRSS-Feed" href="https://navarrepress.com/wp-content/plugins/leaflet-maps-marker/leaflet-georss.php?layer=all" />
<script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":67512,"post_name":"local-narcotics-trafficker-arrested-navarre","post_title":"Local narcotics trafficker arrested in Navarre","post_type":"post","post_author":"6","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":4748,"name":"Local","slug":"local","term_group":0,"term_taxonomy_id":4752,"taxonomy":"category","description":"","parent":0,"count":1438,"filter":"raw","cat_ID":4748,"category_count":1438,"category_description":"","cat_name":"Local","category_nicename":"local","category_parent":0}]; _mmunch['postTags'] = [{"term_id":30429,"name":"Barlow Road","slug":"barlow-road","term_group":0,"term_taxonomy_id":30441,"taxonomy":"post_tag","description":"","parent":0,"count":1,"filter":"raw"},{"term_id":30432,"name":"LSD","slug":"lsd","term_group":0,"term_taxonomy_id":30444,"taxonomy":"post_tag","description":"","parent":0,"count":1,"filter":"raw"},{"term_id":2015,"name":"marijuana","slug":"marijuana","term_group":0,"term_taxonomy_id":2017,"taxonomy":"post_tag","description":"","parent":0,"count":23,"filter":"raw"},{"term_id":30428,"name":"narcotics trafficker","slug":"narcotics-trafficker","term_group":0,"term_taxonomy_id":30440,"taxonomy":"post_tag","description":"","parent":0,"count":1,"filter":"raw"},{"term_id":14813,"name":"Public Information Officer Rich Aloy","slug":"public-information-officer-rich-aloy","term_group":0,"term_taxonomy_id":14825,"taxonomy":"post_tag","description":"","parent":0,"count":10,"filter":"raw"},{"term_id":30431,"name":"red Ford Mustang","slug":"red-ford-mustang","term_group":0,"term_taxonomy_id":30443,"taxonomy":"post_tag","description":"","parent":0,"count":1,"filter":"raw"},{"term_id":742,"name":"Santa Rosa Sheriff's Office","slug":"santa-rosa-sheriffs-office","term_group":0,"term_taxonomy_id":744,"taxonomy":"post_tag","description":"","parent":0,"count":42,"filter":"raw"},{"term_id":30430,"name":"Troy Alexander Duncan","slug":"troy-alexander-duncan","term_group":0,"term_taxonomy_id":30442,"taxonomy":"post_tag","description":"","parent":0,"count":1,"filter":"raw"},{"term_id":4368,"name":"Xanax","slug":"xanax","term_group":0,"term_taxonomy_id":4370,"taxonomy":"post_tag","description":"","parent":0,"count":3,"filter":"raw"}]; _mmunch['postAuthor'] = {"name":"","ID":""};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="mc_mm" data-mailmunch-site-id="379586" async></script>

<script data-cfasync="false" type="text/javascript">
 (function() {
  var oa = document.createElement('script'); oa.type = 'text/javascript';
  oa.async = true; oa.src = 'https://navarrepress.api.oneall.com/socialize/library.js';
  var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(oa, s);
 })();
</script>
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://navarrepress.com"><link rel="https://theeventscalendar.com/" href="https://navarrepress.com/wp-json/tribe/events/v1/" />
<script type="text/javascript">
  var _paq = _paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="https://www.sandpaperpublishing.com/analytics3/";
    _paq.push(['setTrackerUrl', u+'piwik.php']);
    _paq.push(['setSiteId', '20']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'piwik.js'; s.parentNode.insertBefore(g,s);
  })();
</script>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-6930017-1', 'navarrepress.com');
  ga('send', 'pageview');
</script>
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/1371603/BoxAd-Front', [300, 250], 'div-gpt-ad-1384382224685-0').addService(googletag.pubads());
googletag.defineSlot('/1371603/Front_Page_Image', [171, 285], 'div-gpt-ad-1384382224685-1').addService(googletag.pubads());
googletag.defineSlot('/1371603/Right_Skyscraper', [160, 600], 'div-gpt-ad-1384382224685-2').addService(googletag.pubads());
googletag.defineSlot('/1371603/Top-Banner', [728, 90], 'div-gpt-ad-1384382224685-3').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>
<link rel="shortcut icon" href="https://navarrepress.com/wp-content/uploads/2013/11/NP_webicon.png" />

<style type="text/css">
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/1371603/BoxAd-Front', [300, 250], 'div-gpt-ad-1384382224685-0').addService(googletag.pubads());
googletag.defineSlot('/1371603/Front_Page_Image', [171, 285], 'div-gpt-ad-1384382224685-1').addService(googletag.pubads());
googletag.defineSlot('/1371603/Right_Skyscraper', [160, 600], 'div-gpt-ad-1384382224685-2').addService(googletag.pubads());
googletag.defineSlot('/1371603/Top-Banner', [728, 90], 'div-gpt-ad-1384382224685-3').addService(googletag.pubads());
googletag.defineSlot('/1371603/Top-of-Homepage', [728, 90], 'div-gpt-ad-1427222959734-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script></style>
<script type='text/javascript'>
	<!--	
	(function($){
		$.fn.jfontsize = function(opcoes) {
			var $this=$(this);
			var defaults = {
				btnMinusClasseId: '.fontSizeMinus',
				btnPlusClasseId: '.fontSizePlus',
				btnMinusMaxHits: 5,
				btnPlusMaxHits: 5,
				sizeChange: 1
			};

			if(($.isArray(opcoes))||(!opcoes)){
				opcoes = $.extend(defaults, opcoes);
			} else {
				defaults.sizeChange = opcoes;
				opcoes = defaults;
			}

			var limite=new Array();
			var fontsize_padrao=new Array();

			$(this).each(function(i){
				limite[i]=0;
				fontsize_padrao[i];
			})

			$('.fontSizeMinus, .fontSizePlus').removeAttr('href');
			$('.fontSizeMinus, .fontSizePlus').css('cursor', 'pointer');

			/* A- */
			$('.fontSizeMinus').click(function(){
				$this.each(function(i){
					if (limite[i]>(-(opcoes.btnMinusMaxHits))){
						fontsize_padrao[i]=$(this).css('font-size');
						fontsize_padrao[i]=fontsize_padrao[i].replace('px', '');
						fontsize=$(this).css('font-size');
						fontsize=parseInt(fontsize.replace('px', ''));
						fontsize=fontsize-(opcoes.sizeChange);
						fontsize_padrao[i]=fontsize_padrao[i]-(limite[i]*opcoes.sizeChange);
						limite[i]--;
						$(this).css('font-size', fontsize+'px');
					}
				})
			})

			/* A+ */
			$('.fontSizePlus').click(function(){
				$this.each(function(i){
					if (limite[i]<opcoes.btnPlusMaxHits){
						fontsize_padrao[i]=$(this).css('font-size');
						fontsize_padrao[i]=fontsize_padrao[i].replace('px', '');
						fontsize=$(this).css('font-size');
						fontsize=parseInt(fontsize.replace('px', ''));
						fontsize=fontsize+opcoes.sizeChange;
						fontsize_padrao[i]=fontsize_padrao[i]-(limite[i]*opcoes.sizeChange);
						limite[i]++;
						$(this).css('font-size', fontsize+'px');
					}
				})
			})
		};
	})(jQuery);	
	(function($) {
		$.noConflict();
		$(document).ready(function() {
			$(".children").parent("li").addClass("has-child-menu");
			$(".sub-menu").parent("li").addClass("has-child-menu");
			$(".drop").parent("li").addClass("has-child-menu");
			
			$('.fadeimage').hover(
				function() {$(this).stop().animate({ opacity: 0.5 }, 800);},
				function() {$(this).stop().animate({ opacity: 1.0 }, 800);}
			);
			
			$('.mastheadnav li ul,.mainnav li ul,.secondnav li ul').hide().removeClass('fallback');
			$('.mastheadnav > li,.mainnav > li,.secondnav > li').hover(
				function () {
					$('ul', this).stop().slideDown(250);
				},
				function () {
					$('ul', this).stop().slideUp(250);
				}
			);			
						
			$('#tabs-left').tab();
			$('#tabs > li > a').hover( function(){$(this).tab('show');});
			$("ul.tabs").tabs("div.panes > div");
			$("ul.sc_tabs").tabs("div.sc_tabs-content > div");
			
			$('.entry p').jfontsize();
			
			
				$('#bootstartCarousel').carousel({
				interval: 4000,
				pause : 'hover'
				});
							
			$('.mediagallery').contentcarousel({
				// speed for the sliding animation
				sliderSpeed     : 500,
				// easing for the sliding animation
				sliderEasing    : 'easeOutExpo',
				// speed for the item animation (open / close)
				itemSpeed       : 500,
				// easing for the item animation (open / close)
				itemEasing      : 'easeOutExpo',
				// number of items to scroll at a time
				scroll          : 1
			});	
						
			$('a[href="#top"]').click(function(){	$('html, body').animate({scrollTop:0}, 'slow');	return false; });		
			// Responsive Menu (TinyNav)
			$(".menu").tinyNav({
				active: 'current_page_item', // Set the "active" class for default menu
				label: ''
			});
			$(".tinynav").selectbox();
			$('.tooltip-link').tooltip({ placement: 'right'});

		});
	})(jQuery);
	// -->
	</script>
<style type="text/css" id="custom-background-css">
body.custom-background { background-image: url("https://navarrepress.com/wp-content/uploads/2013/12/MG_10013.jpg"); background-position: center top; background-size: auto; background-repeat: no-repeat; background-attachment: fixed; }
</style>

<link rel="stylesheet" href="https://navarrepress.com/wp-content/plugins/easy-columns/css/easy-columns.css" type="text/css" media="screen, projection" />


<meta property="og:locale" content="en_US" />
<meta property="og:site_name" content="Navarre Press" />
<meta property="og:title" content="Local narcotics trafficker arrested in Navarre | Navarre Press" />
<meta property="og:url" content="https://navarrepress.com/local/local-narcotics-trafficker-arrested-navarre/" />
<meta property="og:type" content="article" />
<meta property="og:description" content="Parks car with drugs in plain view of deputies Just after 10 p.m., Nov. 15, the Santa Rosa County Sheriff’s Office received a 911 call in reference to a robbery at the 3000 block of Barlow Road in Navarre. Deputies arrived on scene and could not locate the suspect, described as a black male 6 fee" />
<meta property="og:image" content="https://navarrepress.com/wp-content/uploads/2017/11/Arrested-Troy-Duncan-1.jpg" />
<meta property="article:published_time" content="2017-11-17T10:15:46+00:00" />
<meta property="article:modified_time" content="2017-11-17T10:45:56+00:00" />
<meta property="og:updated_time" content="2017-11-17T10:45:56+00:00" />
<meta property="article:section" content="Local" />
<meta property="article:author" content="https://www.facebook.com/navarrepress" />
<meta property="article:publisher" content="https://business.facebook.com/navarrepress/?business_id=796379453826602" />

<meta itemprop="name" content="Local narcotics trafficker arrested in Navarre | Navarre Press" />
<meta itemprop="description" content="Parks car with drugs in plain view of deputies Just after 10 p.m., Nov. 15, the Santa Rosa County Sheriff’s Office received a 911 call in reference to a robbery at the 3000 block of Barlow Road in Navarre. Deputies arrived on scene and could not locate the suspect, described as a black male 6 fee" />
<meta itemprop="image" content="https://navarrepress.com/wp-content/uploads/2017/11/Arrested-Troy-Duncan-1.jpg" />

<meta name="twitter:title" content="Local narcotics trafficker arrested in Navarre | Navarre Press" />
<meta name="twitter:url" content="https://navarrepress.com/local/local-narcotics-trafficker-arrested-navarre/" />
<meta name="twitter:description" content="Parks car with drugs in plain view of deputies Just after 10 p.m., Nov. 15, the Santa Rosa County Sheriff’s Office received a 911 call in reference to a robbery at the 3000 block of Barlow Road in Navarre. Deputies arrived on scene and could not locate the suspect, described as a black male 6 fee" />
<meta name="twitter:image" content="https://navarrepress.com/wp-content/uploads/2017/11/Arrested-Troy-Duncan-1.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@navarrepress" />



<style type="text/css" media="screen">body {font-size: 12px;font-family: arial;font-weight: normal;color: #555555;background: url(https://navarrepress.com/wp-content/themes/Stylebook-NEW/framework/images/patterns/none.jpg) repeat;}.sitebody p,.entry p, label,input,button,select,textarea, .posttitle.list_posttitle {font-size: 12px;font-family: arial;font-weight: normal;color: #555555;}.posttitle, .posttitle a {font-size: 20px;font-family: arial;font-weight: bold;color: #0e829f;}.posttitle a:hover {color:#12775e;}.posttitle.list_posttitle, .posttitle.list_posttitle a {font-size: 12px;font-family: arial;font-weight: bold;color: #555555;}.posttitle.list_posttitle a:hover {color:#12775e;}.post-lead h1 {font-size: 24px;font-family: arial;font-weight: bold;color: #0e829f;}.post-lead p.subtitle {font-size: 12px;font-family: arial;font-weight: normal;color: #555555;}.post-lead p.subtitle, 
								nav .mastheadnav li ul li a:hover,
								nav .mastheadnav li li.has-child-menu > a:hover,
								.social_header a:hover i,
								nav .mainnav li ul li a:hover,
								nav .mainnav li li.has-child-menu > a:hover,
								nav .secondnav li ul li a:hover,
								nav .secondnav li li.has-child-menu > a:hover,
								#respond .form-submit #submit:hover,
								.follow_us a:hover i,
								footer .about_more,footer .about_more:hover,
								footer h4 span,
								.post-lead span i{ background-color:#6db9e3;}
							
							a,
							.post-column .highlight,
							.inner-cycle .template-pager span.cycle-pager-active,
							#tab-content1 li a:hover,
							.widgetinner a{ color:#6db9e3;}
							.primarybottom_right_firstcol .nav-tabs > li.firsttab.active > a,
							.primarybottom_right_firstcol .nav-tabs > li.firsttab.active > a:hover,
							.primarybottom_right_firstcol .nav-tabs > li.firsttab.active > a:focus,
							.primarybottom_right_firstcol .nav > li.firsttab > a:hover,
							.primarybottom_right_firstcol .nav > li.firsttab > a:focus  {background:#19a585;border: 1px solid #19a585;}
							.primarybottom_right_firstcol #firsttab-content {border-top:3px solid #19a585;}
							.primarybottom_right_firstcol #firsttab-content .tab_moreentries {background:#19a585}
							.primarybottom_right_firstcol .nav-tabs > li.secondtab.active > a,
							.primarybottom_right_firstcol .nav-tabs > li.secondtab.active > a:hover,
							.primarybottom_right_firstcol .nav-tabs > li.secondtab.active > a:focus,
							.primarybottom_right_firstcol .nav > li.secondtab > a:hover,
							.primarybottom_right_firstcol .nav > li.secondtab > a:focus  {background:#bddb8c;border: 1px solid #bddb8c;}
							.primarybottom_right_firstcol #secondtab-content {border-top:3px solid #bddb8c;}
							.primarybottom_right_firstcol #secondtab-content .tab_moreentries {background:#bddb8c}
							.primarybottom_right_firstcol .nav-tabs > li.thirdtab.active > a,
							.primarybottom_right_firstcol .nav-tabs > li.thirdtab.active > a:hover,
							.primarybottom_right_firstcol .nav-tabs > li.thirdtab.active > a:focus,
							.primarybottom_right_firstcol .nav > li.thirdtab > a:hover,
							.primarybottom_right_firstcol .nav > li.thirdtab > a:focus  {background:#1e73be;border: 1px solid #1e73be;}
							.primarybottom_right_firstcol #thirdtab-content {border-top:3px solid #1e73be;}
							.primarybottom_right_firstcol #thirdtab-content .tab_moreentries {background:#1e73be}
							nav .mastheadnav li a:hover,
							.headerquote-inner .quotecaption a,
							.headerquote-inner .quotecaption a:hover
							.headerquote-inner .quotecaption{color:#0e829f;}
							nav .mainnav,
							.featured-cycle .cycle-pager a.cycle-pager-active,
							.primarybottom-left .nav-tabs > li.active > a{background-color:#0e829f}
							.primarybottom-left .nav-tabs > li.active > a{border-color:#0e829f;}</style>
<!--[if IE 7]>
  <![endif]-->

<!--[if lt IE 9]>
	<script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>
<![endif]-->
</head>
<body class="post-template-default single single-post postid-67512 single-format-standard custom-background tribe-no-js">
<div class="pagetools">
<a class="pagetool_item tooltip-link" href="https://navarrepress.com/business/restaurant-style-food-fast-food-pace/" title="Prev post: Restaurant style food with a fast-food pace"><i class="icon-arrow-left"></i></a>
<a class="pagetool_item tooltip-link" href="https://navarrepress.com/headlines/facebook-busts-alleged-club-ii-burglar/" title="Next post: Facebook busts alleged Club II burglar"><i class="icon-arrow-right"></i></a>
<a class="pagetool_item tooltip-link" href="https://navarrepress.com/contact" title="Get in touch with us"><i class="icon-envelope-alt"></i></a> <a class="pagetool_item tooltip-link" href="https://navarrepress.com" title="Go to homepage"><i class="icon-home"></i></a> <a class="pagetool_item tooltip-link" href="https://navarrepress.com/search/" title="Search in site..."><i class="icon-search"></i></a></div>
<div class="container">
<div class="row">
<div class="span12">
<div class="sitebody">
<header class="site-header">
<div class="masthead">
<a href="https://navarrepress.com/subscribe/"><img src="https://navarrepress.com/wp-content/uploads/2014/01/SubscribeNow.gif"></a>
<a href="http://navarrepress.fl.newsmemory.com/" target="_blank"><img src="https://navarrepress.com/wp-content/uploads/2014/01/Read_eEdition.gif"></a>
<a href="https://navarrepress.com/advertise/" target="_blank"><img src="https://navarrepress.com/wp-content/uploads/2014/08/Advertise.gif"></a>
<nav class="masthead-navigation">
<ul class="mastheadnav menu">
<li id="menu-item-46879" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-46879"><a href="http://navarrepress.fl.newsmemory.com/">e-Edition</a>
<ul class="sub-menu">
<li id="menu-item-58534" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58534"><a href="http://navarrepress.fl.newsmemory.com/special.php?&#038;date=20171026">2017 Fall Sports Guide</a></li>
<li id="menu-item-46884" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46884"><a target="_blank" href="http://navarrepress.fl.newsmemory.com/special.php?date=20170615">2017 Visitor&#8217;s Guide</a></li>
<li id="menu-item-46880" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46880"><a target="_blank" href="http://navarrepress.fl.newsmemory.com/special.php?date=20170126">2017 Mind, Body and Spirit</a></li>
<li id="menu-item-46882" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46882"><a target="_blank" href="http://navarrepress.fl.newsmemory.com/special.php?date=20161124">2016 Holiday Happenings</a></li>
<li id="menu-item-46885" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46885"><a target="_blank" href="http://yourschoolcalendar.com">School Calendars</a></li>
<li id="menu-item-57088" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57088"><a href="http://navarrepress.com/wp-content/uploads/2016/09/declass28pages2016.pdf">9/11 Joint Inquiry</a></li>
<li id="menu-item-46886" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46886"><a target="_blank" href="http://navarrepress.fl.newsmemory.com/special.php?date=20140130">FREE edition: January 30, 2016</a></li>
</ul>
</li>
<li id="menu-item-32882" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32882"><a title="Fictitious Name Legal Notice" href="https://navarrepress.com/fictitious-name-legal-notice/">Fictitious Name</a></li>
<li id="menu-item-30804" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30804"><a title="Navarre Area Garage Sales" href="https://navarrepress.com/navarre-area-garage-sales/">Garage Sales</a></li>
<li id="menu-item-43410" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-43410"><a>Tutorials</a>
<ul class="sub-menu">
<li id="menu-item-43411" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43411"><a href="https://www.youtube.com/watch?v=j061S9Mk86A&#038;feature=youtu.be">How to Use the Navarre Press Restaurant Inspection Database</a></li>
</ul>
</li>
<li id="menu-item-60571" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-60571"><a href="http://navarrephotos.com">Photo Gallery</a>
<ul class="sub-menu">
<li id="menu-item-60375" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60375"><a href="http://navarrephotos.com/NP-Issues">By Issue</a></li>
<li id="menu-item-60373" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60373"><a href="http://navarrephotos.com/Sports">Local Sports</a></li>
<li id="menu-item-60374" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60374"><a href="http://navarrephotos.com/Local-Events">Local Events</a></li>
<li id="menu-item-60376" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60376"><a href="http://navarrephotos.com/Naturalizations">Naturalization Ceremonies</a></li>
</ul>
</li>
<li id="menu-item-16160" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-16160"><a href="https://navarrepress.com/contact/">Contact</a>
<ul class="sub-menu">
<li id="menu-item-30805" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30805"><a href="https://navarrepress.com/letter-editor/">Letter to the Editor</a></li>
<li id="menu-item-30765" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30765"><a href="https://navarrepress.com/distribution-locations/">Distribution Locations</a></li>
</ul>
</li>

</ul>
</nav>
<div class="social_header pull-right">
 <a href="http://www.facebook.com/navarrepress" title="Facebook" rel="nofollow">
<i class="icon-facebook pull-left"></i>
</a>

 <a href="http://twitter.com/navarrepress" title="Twitter" rel="nofollow">
<i class="icon-twitter pull-left"></i>
</a>
<a href="https://plus.google.com/+Navarrepress1/posts" title="Google+" rel="nofollow">
<i class="icon-google-plus pull-left"></i>
</a>
<a href="http://www.youtube.com/user/npwebadmin" title="Youtube" rel="nofollow">
<i class="icon-flickr pull-left"></i>
</a>
<a href="http://feedburner.google.com/fb/a/mailverify?uri=navarrepress" title="Email" rel="nofollow">
<i class="icon-envelope-alt pull-left"></i>
</a>
<a href="https://navarrepress.com/feed/" title="Site feed" rel="nofollow">
<i class="icon-rss pull-left"></i>
</a>
</div>
<div class="clearfix"></div>
</div>
<div class="header_2ndrow">
<div class="sitelogo pull-left" style="padding:0px 0px 10px 0px;">
<h1>
<a href="https://navarrepress.com/" title="News for Navarre, Navarre Beach and Gulf Breeze">
<img src="https://navarrepress.com/wp-content/uploads/2014/01/NP-Header1.png" alt="Navarre Press" title="Navarre Press" />
</a>
</h1>
 </div>
<div class="pull-right headerbanner" style="margin-top:0px"><div id='div-gpt-ad-1384382224685-3' style='width:728px;height:90px'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1384382224685-3'); });
</script>
</div>
<br></div>
<div class="clearfix"></div>
</div>
<div class="nav_date pull-left">
<script type="text/javascript">
								<!--
								var mydate=new Date()
								var day=mydate.getDay()
								var month=mydate.getMonth()
								var daym=mydate.getDate()
								if (daym<10)
								daym="0"+daym
								var montharray=new Array("Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec")
								document.write("<span class='gabfire_day'>"+daym+"</span><span class='gabfire_month'>"+montharray[month]+"</span>")
								// -->
							</script>
</div>
<nav class="main-navigation pull-left">
<ul class="mainnav menu pull-right">
<li class="megadp"><a href="https://navarrepress.com/local/" class="drop">Local</a>
<div class="dropdown_col align_left">
<div class="dropdown_inner">
<div class="dropdown_top">
<ul class="greybox">
<li class="cat-item cat-item-20"><a href="https://navarrepress.com/local/community/">Community</a>
</li>
<li class="feed"><a href="https://navarrepress.com/local/feed/">RSS Feed</a></li>
</ul>
<div class="dropdown_entries">

<div class="featuredpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2017%2F11%2FArrested-Troy-Duncan-1.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Local narcotics trafficker arrested in Navarre" title="Local narcotics trafficker arrested in Navarre" /> <h2 class="posttitle">
<a href="https://navarrepress.com/local/local-narcotics-trafficker-arrested-navarre/" rel="bookmark" title="Permalink to Local narcotics trafficker arrested in Navarre">Local narcotics trafficker arres&hellip;</a>
</h2>
<p>
Parks car with drugs in plain view of&hellip;
</p>
</div>

<div class="featuredpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2017%2F03%2Fjones-at-rotary.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Refuge for Women receives $10,000 pledge" title="Refuge for Women receives $10,000 pledge" /> <h2 class="posttitle">
<a href="https://navarrepress.com/local/refuge-women-receives-10000-pledge/" rel="bookmark" title="Permalink to Refuge for Women receives $10,000 pledge">Refuge for Women receives $10,00&hellip;</a>
</h2>
<p>
An anonymous donor has come forward to offer&hellip;
</p>
</div>
<div class="featuredpost lastpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2017%2F11%2FSeniorsStory.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Roundtable provides one-stop shop for senior resources" title="Roundtable provides one-stop shop for senior resources" /> <h2 class="posttitle">
<a href="https://navarrepress.com/local/roundtable-provides-one-stop-shop-senior-resources/" rel="bookmark" title="Permalink to Roundtable provides one-stop shop for senior resources">Roundtable provides one-stop sho&hellip;</a>
</h2>
<p>
Putting valuable information into the hands of senior&hellip;
</p>
</div>
</div>
</div>
<div class="dropdown_bottom">
<div class="dropdown_ad">
</div>
</div>
</div>
</div>
</li>
<li class="megadp"><a href="https://navarrepress.com/lifestyle-leisure/" class="drop">Lifestyle/Leisure</a>
<div class="dropdown_col align_left">
<div class="dropdown_inner">
<div class="dropdown_top">
<ul class="greybox">
 <li class="cat-item cat-item-4765"><a href="https://navarrepress.com/lifestyle-leisure/automotive/">Automotive</a>
</li>
<li class="cat-item cat-item-21"><a href="https://navarrepress.com/lifestyle-leisure/beach/">Beach</a>
</li>
<li class="cat-item cat-item-8545"><a href="https://navarrepress.com/lifestyle-leisure/charity-lifestyle-leisure/">Charity</a>
</li>
<li class="cat-item cat-item-4613"><a href="https://navarrepress.com/lifestyle-leisure/culture/">Culture</a>
</li>
<li class="cat-item cat-item-837"><a href="https://navarrepress.com/lifestyle-leisure/fishing/">Fishing</a>
</li>
<li class="cat-item cat-item-4767"><a href="https://navarrepress.com/lifestyle-leisure/food-and-beverage/">Food and Beverage</a>
</li>
<li class="cat-item cat-item-4768"><a href="https://navarrepress.com/lifestyle-leisure/home-and-garden/">Home and Garden</a>
</li>
<li class="cat-item cat-item-4627"><a href="https://navarrepress.com/lifestyle-leisure/nightlife/">Nightlife</a>
</li>
<li class="cat-item cat-item-7703"><a href="https://navarrepress.com/lifestyle-leisure/pets-lifestyle-leisure/">Pets</a>
</li>
<li class="cat-item cat-item-4632"><a href="https://navarrepress.com/lifestyle-leisure/shopping/">Shopping</a>
</li>
<li class="cat-item cat-item-4735"><a href="https://navarrepress.com/lifestyle-leisure/travel/">Travel</a>
</li>
<li class="cat-item cat-item-5277"><a href="https://navarrepress.com/lifestyle-leisure/zoo-lifestylel-eisure/">Zoo</a>
</li>
 <li class="feed"><a href="https://navarrepress.com/lifestyle-leisure/feed/">RSS Feed</a></li>
</ul>
<div class="dropdown_entries">

<div class="featuredpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2017%2F11%2Fsea-turtle-release.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Reptiles drawn back to pier despite multiple run-ins with fishing hooks" title="Reptiles drawn back to pier despite multiple run-ins with fishing hooks" /> <h2 class="posttitle">
<a href="https://navarrepress.com/local/reptiles-drawn-back-pier-despite-multiple-run-ins-fishing-hooks/" rel="bookmark" title="Permalink to Reptiles drawn back to pier despite multiple run-ins with fishing hooks">Reptiles drawn back to pier desp&hellip;</a>
</h2>
<p>
Okra, a juvenile green sea turtle, has had&hellip;
</p>
</div>

<div class="featuredpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2017%2F11%2FManatee.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Manatee population continues to recover" title="Manatee population continues to recover" /> <h2 class="posttitle">
<a href="https://navarrepress.com/local/manatee-population-continues-recover/" rel="bookmark" title="Permalink to Manatee population continues to recover">Manatee population continues to &hellip;</a>
</h2>
<p>
November is Manatee Awareness Month and the state&hellip;
</p>
</div>
<div class="featuredpost lastpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2017%2F11%2FOutdoors2.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Visiting Gulf Islands will cost a little more in 2018" title="Visiting Gulf Islands will cost a little more in 2018" /> <h2 class="posttitle">
<a href="https://navarrepress.com/local/visiting-gulf-islands-will-cost-little-2018/" rel="bookmark" title="Permalink to Visiting Gulf Islands will cost a little more in 2018">Visiting Gulf Islands will cost &hellip;</a>
</h2>
<p>
Two years after its first price increase in&hellip;
</p>
</div>
 </div>
</div>
<div class="dropdown_bottom">
<div class="dropdown_ad">
</div>
</div>
</div>
</div>
</li>
<li class="megadp"><a href="https://navarrepress.com/sports/" class="drop">Sports</a>
<div class="dropdown_col align_left">
<div class="dropdown_inner">
<div class="dropdown_top">
<ul class="greybox">
<li class="cat-item cat-item-4781"><a href="https://navarrepress.com/sports/baseball-sports-and-games/">Baseball</a>
</li>
<li class="cat-item cat-item-4782"><a href="https://navarrepress.com/sports/basketball-sports-and-games/">Basketball</a>
</li>
<li class="cat-item cat-item-143"><a href="https://navarrepress.com/sports/football/">Football</a>
</li>
<li class="cat-item cat-item-682"><a href="https://navarrepress.com/sports/golf/">Golf</a>
</li>
<li class="cat-item cat-item-4776"><a href="https://navarrepress.com/sports/soccer-sports-and-games/">Soccer</a>
</li>
<li class="cat-item cat-item-7933"><a href="https://navarrepress.com/sports/softball-sports/">Softball</a>
</li>
<li class="cat-item cat-item-5229"><a href="https://navarrepress.com/sports/swimming-sports-games/">Swimming</a>
</li>
<li class="cat-item cat-item-7489"><a href="https://navarrepress.com/sports/volleyball-sports/">Volleyball</a>
</li>
<li class="cat-item cat-item-5248"><a href="https://navarrepress.com/sports/weight-lifting/">Weight Lifting</a>
</li>
<li class="feed"><a href="https://navarrepress.com/sports/feed/">RSS Feed</a></li>
</ul>
<div class="dropdown_entries">

<div class="featuredpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2017%2F11%2FWIL_6265.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Playoff run comes to a painful end for Raiders" title="Playoff run comes to a painful end for Raiders" /> <h2 class="posttitle">
<a href="https://navarrepress.com/sports/playoff-run-comes-painful-end-raiders/" rel="bookmark" title="Permalink to Playoff run comes to a painful end for Raiders">Playoff run comes to a painful e&hellip;</a>
</h2>
<p>
Navarre head coach Jay Walls stood in front&hellip;
</p>
</div>

<div class="featuredpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2017%2F11%2FArgos-1.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Argonauts ready to roll into postseason" title="Argonauts ready to roll into postseason" /> <h2 class="posttitle">
<a href="https://navarrepress.com/sports/argonauts-ready-roll-postseason/" rel="bookmark" title="Permalink to Argonauts ready to roll into postseason">Argonauts ready to roll into pos&hellip;</a>
</h2>
<p>
On Sunday, the University of West Florida received&hellip;
</p>
</div>

<div class="featuredpost lastpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2017%2F11%2FRaiders.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="St. Augustine next stop for Navarre on playoff journey" title="St. Augustine next stop for Navarre on playoff journey" /> <h2 class="posttitle">
<a href="https://navarrepress.com/sports/st-augustine-next-stop-navarre-playoff-journey/" rel="bookmark" title="Permalink to St. Augustine next stop for Navarre on playoff journey">St. Augustine next stop for Nava&hellip;</a>
</h2>
<p>
The game is bigger than the trip. That&hellip;
</p>
</div>
</div>
</div>
<div class="dropdown_bottom">
<div class="dropdown_ad">
</div>
</div>
</div>
</div>
</li>
<li class="megadp"><a href="https://navarrepress.com/education/" class="drop">Education</a>
<div class="dropdown_col align_left">
<div class="dropdown_inner">
<div class="dropdown_top">
<ul class="greybox">
 <li class="cat-item cat-item-4783"><a href="https://navarrepress.com/education/college-education/">College</a>
</li>
<li class="cat-item cat-item-4786"><a href="https://navarrepress.com/education/elementary/">Elementary</a>
</li>
<li class="cat-item cat-item-4784"><a href="https://navarrepress.com/education/high-school-education/">High School</a>
</li>
<li class="cat-item cat-item-7842"><a href="https://navarrepress.com/education/intermediate/">Intermediate</a>
</li>
<li class="cat-item cat-item-4785"><a href="https://navarrepress.com/education/middle-school/">Middle School</a>
</li>
<li class="feed"><a href="https://navarrepress.com/education/feed/">RSS Feed</a></li>
</ul>
<div class="dropdown_entries">

<div class="featuredpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2017%2F11%2FMrs.Mijangos2.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Librarian’s passion for reading makes her Teacher of the Year" title="Librarian’s passion for reading makes her Teacher of the Year" /> <h2 class="posttitle">
<a href="https://navarrepress.com/education/middle-school/librarians-passion-reading-makes-teacher-year/" rel="bookmark" title="Permalink to Librarian’s passion for reading makes her Teacher of the Year">Librarian’s passion for reading &hellip;</a>
</h2>
<p>
The library is a happening place on a&hellip;
</p>
</div>
<div class="featuredpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2017%2F11%2FWatson-classroom.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="“Mama” Watson brings passion, hugs to classroom" title="“Mama” Watson brings passion, hugs to classroom" /> <h2 class="posttitle">
<a href="https://navarrepress.com/education/high-school-education/mama-watson-brings-passion-hugs-classroom/" rel="bookmark" title="Permalink to “Mama” Watson brings passion, hugs to classroom">“Mama” Watson brings passion, hu&hellip;</a>
</h2>
<p>
When Navarre High School teacher Jennifer Watson was&hellip;
</p>
</div>

<div class="featuredpost lastpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2017%2F11%2FProject-WILD-6.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Educators go WILD" title="Educators go WILD" /> <h2 class="posttitle">
<a href="https://navarrepress.com/education/educators-go-wild/" rel="bookmark" title="Permalink to Educators go WILD">Educators go WILD</a>
</h2>
<p>
Despite being closed to the public, the Navarre&hellip;
</p>
</div>
</div>
</div>
<div class="dropdown_bottom">
<div class="dropdown_ad">
</div>
</div>
</div>
</div>
</li>
<li class="megadp"><a href="https://navarrepress.com/arts-entertainment/" class="drop">Arts/Entertainment</a>
<div class="dropdown_col align_right">
<div class="dropdown_inner">
<div class="dropdown_top">
<ul class="greybox">
 <li class="cat-item cat-item-4612"><a href="https://navarrepress.com/arts-entertainment/celebrity/">Celebrity</a>
</li>
<li class="cat-item cat-item-4617"><a href="https://navarrepress.com/arts-entertainment/events-festivals/">Events &amp; Festivals</a>
</li>
<li class="feed"><a href="https://navarrepress.com/arts-entertainment/feed/">RSS Feed</a></li>
</ul>
<div class="dropdown_entries">

<div class="featuredpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2017%2F10%2Fsea-turtle-extrav.-2.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Sea Turtle Extravaganza promotes conservation" title="Sea Turtle Extravaganza promotes conservation" /> <h2 class="posttitle">
<a href="https://navarrepress.com/local/sea-turtle-extravaganza-promotes-conservation/" rel="bookmark" title="Permalink to Sea Turtle Extravaganza promotes conservation">Sea Turtle Extravaganza promotes&hellip;</a>
</h2>
<p>
Arriving at Navarre Beach Saturday morning, visitors were&hellip;
</p>
</div>

<div class="featuredpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2017%2F10%2Fkids-in-costume.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Halloween events and festivities" title="Halloween events and festivities" /> <h2 class="posttitle">
<a href="https://navarrepress.com/arts-entertainment/events-festivals/halloween-events-festivities-2/" rel="bookmark" title="Permalink to Halloween events and festivities">Halloween events and festivities</a>
</h2>
<p>
Halloween events and family friendly festivities will be&hellip;
</p>
</div>

<div class="featuredpost lastpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2017%2F10%2FFieldofScreams2.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Field of Screams offers frightening experience for haunted house lovers" title="Field of Screams offers frightening experience for haunted house lovers" /> <h2 class="posttitle">
<a href="https://navarrepress.com/local/field-screams-offers-frightening-experience-haunted-house-lovers/" rel="bookmark" title="Permalink to Field of Screams offers frightening experience for haunted house lovers">Field of Screams offers frighten&hellip;</a>
</h2>
<p>
No one was afraid of Pensacola’s baseball team&hellip;
</p>
</div>
 </div>
</div>
<div class="dropdown_bottom">
<div class="dropdown_ad">
 </div>
</div>
</div>
</div>
</li>
<li class="megadp"><a href="https://navarrepress.com/law-and-order/crime/" class="drop">Crime</a>
<div class="dropdown_col align_left">
<div class="dropdown_inner">
<div class="dropdown_top">
<ul class="greybox">
<li class="cat-item-none">No categories</li> <li class="feed"><a href="https://navarrepress.com/law-and-order/crime/feed/">RSS Feed</a></li>
</ul>
<div class="dropdown_entries">
<div class="featuredpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2017%2F09%2FArrested_800x500.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Santa Rosa County Arrests" title="Santa Rosa County Arrests" /> <h2 class="posttitle">
<a href="https://navarrepress.com/law-and-order/crime/arrests-2/" rel="bookmark" title="Permalink to Santa Rosa County Arrests">Santa Rosa County Arrests</a>
</h2>
<p>
November 5 &#8211; 13, 2017 October 29 &#8211;&hellip;
</p>
</div>
<div class="featuredpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2013%2F12%2FNP-Police.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Teens assault victim with chicken bone" title="Teens assault victim with chicken bone" /> <h2 class="posttitle">
<a href="https://navarrepress.com/law-and-order/crime/teens-assault-victim-chicken-bone/" rel="bookmark" title="Permalink to Teens assault victim with chicken bone">Teens assault victim with chicke&hellip;</a>
</h2>
<p>
Two teenaged detainees of a juvenile justice facility&hellip;
</p>
</div>
<div class="featuredpost lastpost">
<img src="https://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=https%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2017%2F09%2F20170911_103113.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Vandal tags home, car with hate" title="Vandal tags home, car with hate" /> <h2 class="posttitle">
<a href="https://navarrepress.com/headlines/vandal-tags-home-car-hate/" rel="bookmark" title="Permalink to Vandal tags home, car with hate">Vandal tags home, car with hate</a>
</h2>
<p>
“Kill yourself.” Those harsh words in big, black&hellip;
</p>
</div>
</div>
</div>
<div class="dropdown_bottom">
<div class="dropdown_ad">
</div>
</div>
</div>
</div>
</li>
<li id="menu-item-41055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41055"><a href="http://navarrepress.com/?cat=8360">REAL ESTATE</a></li>
<li id="menu-item-47200" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47200"><a href="http://navarrepress.fl.newsmemory.com/special.php?date=20150820">Sample Edition</a></li>
</ul>
</nav>
<nav class="second-navigation menu pull-left">
<ul class="secondnav pull-right">
<li id="menu-item-31838" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31838"><a href="https://navarrepress.com/state/">State</a></li>
<li id="menu-item-16151" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16151"><a href="https://navarrepress.com/politics/">Politics</a></li>
<li id="menu-item-30860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30860"><a href="https://navarrepress.com/health/">Health</a></li>
<li id="menu-item-30872" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-30872"><a title="Lifestyle and Leisure" href="https://navarrepress.com/lifestyle-leisure/">Lifestyle</a>
<ul class="sub-menu">
<li id="menu-item-16152" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16152"><a href="https://navarrepress.com/religion/">Religion</a></li>
</ul>
</li>
<li id="menu-item-16153" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16153"><a title="Science and Environment" href="https://navarrepress.com/science-environment/">Science</a></li>
<li id="menu-item-32394" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32394"><a href="https://navarrepress.com/technology-2/">Technology</a></li>
<li id="menu-item-30853" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-30853"><a target="_blank" href="http://navarrepress.fl.newsmemory.com/">e-Edition</a>
<ul class="sub-menu">
<li id="menu-item-60363" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60363"><a href="http://navarrepress.fl.newsmemory.com/special.php?&#038;date=20171026">2017 Fall Sports Guide</a></li>
<li id="menu-item-42878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42878"><a href="http://navarrepress.fl.newsmemory.com/special.php?date=20170126">2017 Mind, Body and Spirit</a></li>
<li id="menu-item-60364" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60364"><a href="http://navarrepress.fl.newsmemory.com/special.php?date=20170615">2017 Visitors Guide</a></li>
<li id="menu-item-41755" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41755"><a href="http://navarrepress.fl.newsmemory.com/special.php?date=20161124">2016 Holiday Happenings</a></li>
<li id="menu-item-30964" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30964"><a target="_blank" href="http://yourschoolcalendar.com">School Calendars</a></li>
<li id="menu-item-30962" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30962"><a target="_blank" href="http://navarrepress.fl.newsmemory.com/special.php?date=20140130">FREE edition: January 30th</a></li>
<li id="menu-item-30850" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30850"><a target="_blank" href="/loveagram.html">Place a Love-A-Gram!</a></li>
</ul>
</li>
<li id="menu-item-36177" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36177"><a href="http://navarrepress.com/?post_type=tribe_events">Upcoming Events</a></li>
</ul>
</nav>
<div class="clearfix"></div>
<section id="bootstartCarousel" class="carousel slide">
<div class="carousel-inner">

<div class="item active">
<h2><a href="https://navarrepress.com/sports/playoff-run-comes-painful-end-raiders/" rel="bookmark" title="Permalink to Playoff run comes to a painful end for Raiders">Playoff run comes to a painful end for Raiders</a></h2>
</div>

<div class="item ">
<h2><a href="https://navarrepress.com/headlines/gulf-breeze-faces-state-audit/" rel="bookmark" title="Permalink to Gulf Breeze faces state audit">Gulf Breeze faces state audit</a></h2>
</div>

<div class="item ">
<h2><a href="https://navarrepress.com/headlines/facebook-busts-alleged-club-ii-burglar/" rel="bookmark" title="Permalink to Facebook busts alleged Club II burglar">Facebook busts alleged Club II burglar</a></h2>
</div>

<div class="item ">
<h2><a href="https://navarrepress.com/local/local-narcotics-trafficker-arrested-navarre/" rel="bookmark" title="Permalink to Local narcotics trafficker arrested in Navarre">Local narcotics trafficker arrested in Navarre</a></h2>
</div>

<div class="item ">
<h2><a href="https://navarrepress.com/business/restaurant-style-food-fast-food-pace/" rel="bookmark" title="Permalink to Restaurant style food with a fast-food pace">Restaurant style food with a fast-food pace</a></h2>
</div>

<div class="item ">
<h2><a href="https://navarrepress.com/5-things-to-know-in-florida/10-things-know-friday-3/" rel="bookmark" title="Permalink to 10 Things to Know for Friday">10 Things to Know for Friday</a></h2>
</div>

<div class="item ">
<h2><a href="https://navarrepress.com/local/refuge-women-receives-10000-pledge/" rel="bookmark" title="Permalink to Refuge for Women receives $10,000 pledge">Refuge for Women receives $10,000 pledge</a></h2>
</div>
 </div>
<a class="left carousel-control" href="#bootstartCarousel" data-slide="prev">&lsaquo;</a>
<a class="right carousel-control" href="#bootstartCarousel" data-slide="next">&rsaquo;</a>
</section>
<div class="clearfix"></div>
<script>
document.addEventListener( 'wpcf7mailsent', function( event ) {
    location = 'https://navarrepress.com/payment-please/';
}, false );
</script>
</header>
<div class="post-container">


<section class="post-lead">
<h1 class="post-title">Local narcotics trafficker arrested in Navarre</h1>
<p class="single_postmeta">
<span>By <a href="https://navarrepress.com/author/staffreporter/">Staff Reporters</a> on November 17, 2017</span>
<span>
<a rel="nofollow" href="#" id="increase-font" class="fontsize-button fontSizeMinus" title="Decrease font size"><i class="icon-minus-sign"></i></a>
<a rel="nofollow" href="#" id="decrease-font" class="fontsize-button fontSizePlus" title="Increase font size"><i class="icon-plus-sign"></i></a>
<a rel="nofollow" href="javascript:window.print()" class="print-this-page" title="Print this post"><i class="icon-print"></i></a>
<a class="email-this-page" href="/cdn-cgi/l/email-protection#08377b7d6a626d6b7c3546697e697a7a6d2d3a38587a6d7b7b2d3a382d3b492d3a3844676b69642d3a3866697a6b677c616b7b2d3a387c7a696e6e616b636d7a2d3a38697a7a6d7b7c6d6c2d3a3861662d3a3846697e697a7a6d2e696578336a676c7135412d3a387a6d6b6765656d666c2d3a387c60617b2d3a3878696f6d2d3b492d3a3844676b69642d3a3866697a6b677c616b7b2d3a387c7a696e6e616b636d7a2d3a38697a7a6d7b7c6d6c2d3a3861662d3a3846697e697a7a6d262d384951677d2d3a386b69662d3a387a6d696c2d3a38617c2d3a3867662d3b492d3a38607c7c787b2d3b492d3a4e2d3a4e66697e697a7a6d787a6d7b7b266b67652d3a4e64676b69642d3a4e64676b69642566697a6b677c616b7b257c7a696e6e616b636d7a25697a7a6d7b7c6d6c2566697e697a7a6d2d3a4e" title="Send by email : Local narcotics trafficker arrested in Navarre"><i class="icon-envelope-alt"></i></a> </span>
</p>
</section>
<section class="postbody-wrapper postlayout-default">
<div class="post-column pull-left">
<article class="entry post-67512 post type-post status-publish format-standard has-post-thumbnail hentry category-local tag-barlow-road tag-lsd tag-marijuana tag-narcotics-trafficker tag-public-information-officer-rich-aloy tag-red-ford-mustang tag-santa-rosa-sheriffs-office tag-troy-alexander-duncan tag-xanax last_archivepost">
<div class='mailmunch-forms-before-post' style='display: none !important;'></div><p><strong>Parks car with drugs in plain view of deputies</strong></p>
<p>Just after 10 p.m., Nov. 15, the Santa Rosa County Sheriff’s Office received a 911 call in reference to a robbery at the 3000 block of Barlow Road in Navarre. Deputies arrived on scene and could not locate the suspect, described as a black male 6 feet 3 inches tall, weighing 230 lbs. and wearing gray shorts, a black hoodie, black sneakers and had a small firearm. No one was injured during the course of the robbery.</p>
<p>According to the arrest report, during the robbery investigation, a red Ford Mustang drove quickly down the road toward deputies. The vehicle swerved around marked Sheriff’s Office patrol cars and came to an abrupt stop next to deputies.</p>
<p>Troy Alexander Duncan exited the vehicle. In plain view to deputies, there was a large canning jar full of marijuana sitting in the back seat. Duncan was immediately detained. Further investigation lead deputies to find 11 full canning jars of marijuana, a bag full of Xanax pills and a bag containing strips of LSD.</p><div class='mailmunch-forms-in-post-middle' style='display: none !important;'></div>
<p>Duncan was arrested and transported to the Santa Rosa County jail where he was issued a bond of $59,500.00.</p>
<p>The robbery remains an active investigation.</p>
<div id="attachment_67513" style="width: 250px" class="wp-caption alignleft"><img class="size-medium wp-image-67513" src="https://navarrepress.com/wp-content/uploads/2017/11/Duncan-mug-240x300.jpg" alt="Troy Alexander Duncan" width="240" height="300" srcset="https://navarrepress.com/wp-content/uploads/2017/11/Duncan-mug-240x300.jpg 240w, https://navarrepress.com/wp-content/uploads/2017/11/Duncan-mug.jpg 768w" sizes="(max-width: 240px) 100vw, 240px" /><p class="wp-caption-text">Duncan</p></div>
</p><div class='mailmunch-forms-after-post' style='display: none !important;'></div><section id="gab_contact_widget-5" class="widget gab_contact_widget"><div class="widgetinner"><h3 class="widgettitle">Contact Us</h3>
<div class='gab_contact_logocont'><img src='https://navarrepress.com/wp-content/uploads/2013/11/aplogo.png' class='aligncenter' alt='Navarre Press' /></div><address><p>7502 Harvest Village Ct.<br />
Navarre FL 32566</p>
<a href="/cdn-cgi/l/email-protection#cea7a0a8a18ea0afb8afbcbcabbebcabbdbde0ada1a3"><span class="__cf_email__" data-cfemail="036a6d656c436d62756271716673716670702d606c6e">[email&#160;protected]</span></a><br />850-939-8040</address><div class='clear'></div></div></section>
<section id="text-23" class="widget widget_text"><div class="widgetinner"><h3 class="widgettitle">Social Connections</h3>
<div class="textwidget">
<div id="oa_social_login_container"></div>
<script src="/cdn-cgi/scripts/0e574bed/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
 var _oneall = _oneall || [];
 _oneall.push(['social_login', 'set_callback_uri', window.location.href]);
 _oneall.push(['social_login', 'set_providers', ['facebook', 'google', 'instagram', 'linkedin', 'twitter', 'vimeo', 'windowslive', 'wordpress', 'yahoo', 'youtube']]);
 _oneall.push(['social_login', 'do_render_ui', 'oa_social_login_container']);
</script></div>
</div></section>
<section id="text-15" class="widget widget_text"><div class="widgetinner"><h3 class="widgettitle">Sign Up for Our Newsletter</h3>
<div class="textwidget"><div role="form" class="wpcf7" id="wpcf7-f32884-p67512-o1" lang="en-US" dir="ltr">
<div class="screen-reader-response"></div>
<form action="/local/local-narcotics-trafficker-arrested-navarre/#wpcf7-f32884-p67512-o1" method="post" class="wpcf7-form" novalidate="novalidate">
<div style="display: none;">
<input type="hidden" name="_wpcf7" value="32884" />
<input type="hidden" name="_wpcf7_version" value="4.9.1" />
<input type="hidden" name="_wpcf7_locale" value="en_US" />
<input type="hidden" name="_wpcf7_unit_tag" value="wpcf7-f32884-p67512-o1" />
<input type="hidden" name="_wpcf7_container_post" value="67512" />
</div>
<p>Your Name<br />
<span class="wpcf7-form-control-wrap FirstName"><input type="text" name="FirstName" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-validates-as-required" aria-required="true" aria-invalid="false" placeholder="First" /></span> <span class="wpcf7-form-control-wrap LastName"><input type="text" name="LastName" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-validates-as-required" aria-required="true" aria-invalid="false" placeholder="Last" /></span></p>
<p>Your Email<br />
<span class="wpcf7-form-control-wrap your-email"><input type="email" name="your-email" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-email wpcf7-validates-as-required wpcf7-validates-as-email" aria-required="true" aria-invalid="false" /></span> </p>
<p><span class="wpcf7-form-control-wrap ctct-406"><span class="wpcf7-form-control wpcf7-ctct"><div><input type="hidden" value="2139240580" name="ctct-406[]" />
</div></span></span> </p>
<p><input type="hidden" name="contact_form_7_recaptcha" value="g-recaptcha-0fM46eLW1M2A4al" class="g-recaptcha-explicit-id"><div id="g-recaptcha-0fM46eLW1M2A4al"></div><span class="wpcf7-form-control-wrap g-recaptcha-explicit" data-sitekey="6LeMowgAAAAAAIwe3AqkBZn9cJkFl98avteo_Tgu"></span></p>
<p><input type="submit" value="Sign Up" class="wpcf7-form-control wpcf7-submit" /></p>
<div class="wpcf7-response-output wpcf7-display-none"></div></form></div></div>
</div></section>
<section id="gabfire_search_widget-2" class="widget gabfire_search_widget"><div class="widgetinner"><h3 class="widgettitle">Search in Site</h3>
<form class="gabfire_search_style1" action="https://navarrepress.com/">
<fieldset style="background:#efefef;border:1px solid #eee;">
<input type="text" style="width:80%;background:#efefef" class="gab_search_text" name="s" value="Search..." onfocus="if (this.value == 'Search...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search...';}" />
<input type="submit" class="submit_style1" alt="Search..." />
<div class="clearfix"></div>
</fieldset>
</form>
<div class='clear'></div></div></section>

<div id="comments">
<p>
You must be logged in to post a comment
<a href="https://navarrepress.com/wp-login.php?redirect_to=https%3A%2F%2Fnavarrepress.com%2Flocal%2Flocal-narcotics-trafficker-arrested-navarre%2F">
Login </a>
</p>
</div> </article>
</div>
<aside id="sidebar" class="sidebar pull-right">
<div class="sidebarbanner">

<div id='div-gpt-ad-1415637387971-0' style='width:300px;height:250px'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1415637387971-0'); });
</script>
</div> </div>
<section id="recent-posts-2" class="widget widget_recent_entries"><div class="widgetinner"> <h3 class="widgettitle">Recent Posts</h3>
<ul>
<li>
<a href="https://navarrepress.com/sports/playoff-run-comes-painful-end-raiders/">Playoff run comes to a painful end for Raiders</a>
</li>
<li>
<a href="https://navarrepress.com/headlines/gulf-breeze-faces-state-audit/">Gulf Breeze faces state audit</a>
</li>
<li>
<a href="https://navarrepress.com/headlines/facebook-busts-alleged-club-ii-burglar/">Facebook busts alleged Club II burglar</a>
</li>
<li>
<a href="https://navarrepress.com/local/local-narcotics-trafficker-arrested-navarre/">Local narcotics trafficker arrested in Navarre</a>
</li>
<li>
<a href="https://navarrepress.com/business/restaurant-style-food-fast-food-pace/">Restaurant style food with a fast-food pace</a>
</li>
</ul>
</div></section>
<section id="text-24" class="widget widget_text"><div class="widgetinner"><h3 class="widgettitle">Social Connections</h3>
<div class="textwidget">
<div id="oa_social_login_container"></div>
<script type="text/javascript">
 var _oneall = _oneall || [];
 _oneall.push(['social_login', 'set_callback_uri', window.location.href]);
 _oneall.push(['social_login', 'set_providers', ['facebook', 'google', 'instagram', 'linkedin', 'twitter', 'vimeo', 'windowslive', 'wordpress', 'yahoo', 'youtube']]);
 _oneall.push(['social_login', 'do_render_ui', 'oa_social_login_container']);
</script></div>
</div></section>
</aside>
<div class="clearfix"></div>
</section>
</div>
 </div>
</div> 
</div>
</div>
<section class="container-fluid follow_us">
<div class="container">
<div class="row">
<div class="span2 first-followus-div">
<a href="http://www.facebook.com/navarrepress" rel="nofollow">
<i class="icon-facebook icon-2x pull-left"></i>
<span class="follow_us_linktitle">Facebook</span>
<span class="follow_us_linkdesc">Friend Us</span>
</a>
</div>
<div class="span2">
<a href="http://twitter.com/navarrepress" rel="nofollow">
<i class="icon-twitter icon-2x pull-left"></i>
<span class="follow_us_linktitle">Twitter</span>
<span class="follow_us_linkdesc">Follow Us</span>
</a>
</div>
<div class="span2 third-followus-div">
<a href="https://plus.google.com/+Navarrepress1/posts" rel="nofollow">
<i class="icon-google-plus icon-2x pull-left"></i>
<span class="follow_us_linktitle">Google+</span>
<span class="follow_us_linkdesc">Circle Us</span>
</a>
</div>
<div class="span2 text-align-right">
</div>
<div class="span2 text-align-right">
</div>
<div class="span2 text-align-right last-followus-div">
<a href="https://navarrepress.com/feed/" rel="nofollow">
<i class="icon-rss icon-2x pull-right"></i>
<span class="follow_us_linktitle">RSS</span>
<span class="follow_us_linkdesc">Site Feed</span>
</a>
</div>
<div class="clearfix"></div>
</div>
</div>
</section>
<footer class="container-fluid footer">
<div class="container">
<div class="row">
<div class="span4">
<section id="nav_menu-4" class="widget widget_nav_menu"><div class="widgetinner"><div class="menu-footer-menu-2-container"><ul id="menu-footer-menu-2" class="menu"><li id="menu-item-33437" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33437"><a target="_blank" href="https://navarrepress.com/wp-content/uploads/2017/07/Media_Kit_2017-1.pdf">Advertising</a>
<ul class="sub-menu">
<li id="menu-item-33436" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33436"><a target="_blank" href="http://navarrepress.com/advertise/billboards/">Billboard</a></li>
<li id="menu-item-33438" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33438"><a target="_blank" href="http://navarrepress.com/advertise/healthy-living/">Healthy Living</a></li>
<li id="menu-item-33439" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33439"><a target="_blank" href="https://navarrepress.com/advertise/onthemenu/">On the Menu</a></li>
<li id="menu-item-33440" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33440"><a target="_blank" href="http://navarrepress.com/advertise/outdoors/">Outdoors</a></li>
<li id="menu-item-33442" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33442"><a target="_blank" href="http://navarrepress.com/advertise/pets/">Pets</a></li>
<li id="menu-item-54241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54241"><a href="http://navarrepress.com/wp-content/uploads/2016/05/voters_guide_2016-4.pdf">Voter&#8217;s Guide</a></li>
</ul>
</li>
<li id="menu-item-36332" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36332"><a href="https://navarrepress.com/law-and-order/legal-notices-law-and-order/">Legal Notices</a></li>
<li id="menu-item-33444" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33444"><a href="https://navarrepress.com/distribution-locations/">Distribution Locations</a></li>
<li id="menu-item-60216" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60216"><a href="http://navarrepress.com/?page_id=60218">Partner Publications</a></li>
<li id="menu-item-33445" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33445"><a href="https://navarrepress.com/letter-editor/">Letter to the Editor</a></li>
<li id="menu-item-33447" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33447"><a href="https://navarrepress.com/employment/">Employment</a></li>
<li id="menu-item-38369" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38369"><a href="https://navarrepress.com/weather-terms/">Weather Terms</a></li>
<li id="menu-item-33446" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33446"><a href="https://navarrepress.com/contact/">Contact</a></li>
<li id="menu-item-33448" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33448"><a href="https://navarrepress.com/terms-service/">Terms of Service</a></li>
<li id="menu-item-33449" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33449"><a href="https://navarrepress.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-33451" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33451"><a href="https://navarrepress.com/site-map/">Site Map</a></li>
</ul></div></div></section>
 </div>
<div class="span4">
<section id="archives-4" class="widget widget_archive"><div class="widgetinner"><h3 class="widgettitle">Archives</h3>
<label class="screen-reader-text" for="archives-dropdown-4">Archives</label>
<select id="archives-dropdown-4" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
<option value="">Select Month</option>
<option value='https://navarrepress.com/2017/11/'> November 2017 &nbsp;(106)</option>
<option value='https://navarrepress.com/2017/10/'> October 2017 &nbsp;(175)</option>
<option value='https://navarrepress.com/2017/09/'> September 2017 &nbsp;(162)</option>
<option value='https://navarrepress.com/2017/08/'> August 2017 &nbsp;(167)</option>
<option value='https://navarrepress.com/2017/07/'> July 2017 &nbsp;(151)</option>
<option value='https://navarrepress.com/2017/06/'> June 2017 &nbsp;(145)</option>
<option value='https://navarrepress.com/2017/05/'> May 2017 &nbsp;(145)</option>
<option value='https://navarrepress.com/2017/04/'> April 2017 &nbsp;(161)</option>
<option value='https://navarrepress.com/2017/03/'> March 2017 &nbsp;(162)</option>
<option value='https://navarrepress.com/2017/02/'> February 2017 &nbsp;(148)</option>
<option value='https://navarrepress.com/2017/01/'> January 2017 &nbsp;(151)</option>
<option value='https://navarrepress.com/2016/12/'> December 2016 &nbsp;(126)</option>
<option value='https://navarrepress.com/2016/11/'> November 2016 &nbsp;(167)</option>
<option value='https://navarrepress.com/2016/10/'> October 2016 &nbsp;(171)</option>
<option value='https://navarrepress.com/2016/09/'> September 2016 &nbsp;(168)</option>
<option value='https://navarrepress.com/2016/08/'> August 2016 &nbsp;(158)</option>
<option value='https://navarrepress.com/2016/07/'> July 2016 &nbsp;(151)</option>
<option value='https://navarrepress.com/2016/06/'> June 2016 &nbsp;(164)</option>
<option value='https://navarrepress.com/2016/05/'> May 2016 &nbsp;(133)</option>
<option value='https://navarrepress.com/2016/04/'> April 2016 &nbsp;(153)</option>
<option value='https://navarrepress.com/2016/03/'> March 2016 &nbsp;(160)</option>
<option value='https://navarrepress.com/2016/02/'> February 2016 &nbsp;(135)</option>
<option value='https://navarrepress.com/2016/01/'> January 2016 &nbsp;(146)</option>
<option value='https://navarrepress.com/2015/12/'> December 2015 &nbsp;(147)</option>
<option value='https://navarrepress.com/2015/11/'> November 2015 &nbsp;(143)</option>
<option value='https://navarrepress.com/2015/10/'> October 2015 &nbsp;(174)</option>
<option value='https://navarrepress.com/2015/09/'> September 2015 &nbsp;(160)</option>
<option value='https://navarrepress.com/2015/08/'> August 2015 &nbsp;(156)</option>
<option value='https://navarrepress.com/2015/07/'> July 2015 &nbsp;(161)</option>
<option value='https://navarrepress.com/2015/06/'> June 2015 &nbsp;(169)</option>
<option value='https://navarrepress.com/2015/05/'> May 2015 &nbsp;(132)</option>
<option value='https://navarrepress.com/2015/04/'> April 2015 &nbsp;(176)</option>
<option value='https://navarrepress.com/2015/03/'> March 2015 &nbsp;(172)</option>
<option value='https://navarrepress.com/2015/02/'> February 2015 &nbsp;(140)</option>
<option value='https://navarrepress.com/2015/01/'> January 2015 &nbsp;(148)</option>
<option value='https://navarrepress.com/2014/12/'> December 2014 &nbsp;(143)</option>
<option value='https://navarrepress.com/2014/11/'> November 2014 &nbsp;(168)</option>
<option value='https://navarrepress.com/2014/10/'> October 2014 &nbsp;(183)</option>
<option value='https://navarrepress.com/2014/09/'> September 2014 &nbsp;(149)</option>
<option value='https://navarrepress.com/2014/08/'> August 2014 &nbsp;(193)</option>
<option value='https://navarrepress.com/2014/07/'> July 2014 &nbsp;(194)</option>
<option value='https://navarrepress.com/2014/06/'> June 2014 &nbsp;(140)</option>
<option value='https://navarrepress.com/2014/05/'> May 2014 &nbsp;(141)</option>
<option value='https://navarrepress.com/2014/04/'> April 2014 &nbsp;(124)</option>
<option value='https://navarrepress.com/2014/03/'> March 2014 &nbsp;(120)</option>
<option value='https://navarrepress.com/2014/02/'> February 2014 &nbsp;(101)</option>
<option value='https://navarrepress.com/2014/01/'> January 2014 &nbsp;(98)</option>
<option value='https://navarrepress.com/2013/12/'> December 2013 &nbsp;(85)</option>
<option value='https://navarrepress.com/2013/11/'> November 2013 &nbsp;(75)</option>
<option value='https://navarrepress.com/2013/10/'> October 2013 &nbsp;(10)</option>
<option value='https://navarrepress.com/2013/01/'> January 2013 &nbsp;(3)</option>
</select>
</div></section>
<section id="gab_contact_widget-8" class="widget gab_contact_widget"><div class="widgetinner"><h3 class="widgettitle">Contact</h3>
<address><p>7502 Harvest Village Ct. Navarre, FL 32566</p>
<a href="/cdn-cgi/l/email-protection#cea7a0a8a18ea0afb8afbcbcabbebcabbdbde0ada1a3"><span class="__cf_email__" data-cfemail="85ecebe3eac5ebe4f3e4f7f7e0f5f7e0f6f6abe6eae8">[email&#160;protected]</span></a><br />(850) 939 - 8040</address><div class='clear'></div></div></section>
<section id="sidebarlogin-4" class="widget widget_sidebarlogin"><div class="widgetinner"><h3 class="widgettitle">Login</h3>
<form name="loginform" id="loginform" action="https://navarrepress.com/wp-login.php" method="post">
<p class="login-username">
<label for="user_login">Username</label>
<input type="text" name="log" id="user_login" class="input" value="" size="20" />
</p>
<p class="login-password">
<label for="user_pass">Password</label>
<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" />
</p>
<p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" /> Remember Me</label></p>
<p class="login-submit">
<input type="submit" name="wp-submit" id="wp-submit" class="button button-primary" value="Log In" />
<input type="hidden" name="redirect_to" value="https://navarrepress.com" />
</p>
</form> <p id="reglost">
<a href="https://navarrepress.com/wp-login.php?action=lostpassword&redirect_to=https://navarrepress.com?sli=lost" rel="nofollow" title="Forgot Password">Forgot Password?</a> </p>
</div></section>
</div>
<div class="span4">
 <section id="recent-posts-4" class="widget widget_recent_entries"><div class="widgetinner"> <h3 class="widgettitle">Recent Posts</h3>
<ul>
<li>
<a href="https://navarrepress.com/sports/playoff-run-comes-painful-end-raiders/">Playoff run comes to a painful end for Raiders</a>
</li>
<li>
<a href="https://navarrepress.com/headlines/gulf-breeze-faces-state-audit/">Gulf Breeze faces state audit</a>
</li>
<li>
<a href="https://navarrepress.com/headlines/facebook-busts-alleged-club-ii-burglar/">Facebook busts alleged Club II burglar</a>
</li>
<li>
<a href="https://navarrepress.com/local/local-narcotics-trafficker-arrested-navarre/">Local narcotics trafficker arrested in Navarre</a>
</li>
<li>
<a href="https://navarrepress.com/business/restaurant-style-food-fast-food-pace/">Restaurant style food with a fast-food pace</a>
</li>
</ul>
</div></section>
<section id="text-31" class="widget widget_text"><div class="widgetinner"><h3 class="widgettitle">Social Connections</h3>
<div class="textwidget">
<div id="oa_social_login_container"></div>
<script src="/cdn-cgi/scripts/0e574bed/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
 var _oneall = _oneall || [];
 _oneall.push(['social_login', 'set_callback_uri', window.location.href]);
 _oneall.push(['social_login', 'set_providers', ['facebook', 'google', 'instagram', 'linkedin', 'twitter', 'vimeo', 'windowslive', 'wordpress', 'yahoo', 'youtube']]);
 _oneall.push(['social_login', 'do_render_ui', 'oa_social_login_container']);
</script></div>
</div></section>
</div>
</div>
</div>
</footer>
<section class="container-fluid footer_meta">
<div class="container">
<div class="row">
<div class="span6 footer-left-side">
<a href="#top" title="Navarre Press"><strong>&uarr;</strong> Navarre Press</a>
</div>
<div class="span6 footer-right-side">
© Copyright 2016-2020 Sandpaper Publishing, Inc.
<a href="http://wordpress.org/" title="Semantic Personal Publishing Platform">Powered by WordPress</a> -
Designed by <a href="http://www.gabfirethemes.com/" title="Premium WordPress Themes">Gabfire Themes</a> &nbsp;
 <script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>


<div id="fb-root"></div>
<script type='text/javascript'>
		<!--
		(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));
		// -->
		</script>
<script type='text/javascript'> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};/* ]]> */ </script><link rel='stylesheet' id='font-awesome-ie7-css' href='https://navarrepress.com/wp-content/themes/Stylebook-NEW/framework/font-awesome/css/font-awesome-ie7.min.css?ver=4.8.3' type='text/css' media='all' />
<script type='text/javascript' src='https://navarrepress.com/wp-includes/js/comment-reply.min.js?ver=4.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/navarrepress.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://navarrepress.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9.1'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-content/plugins/gabfire-widget-pack/js/jquery.tools.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://navarrepress.com/wp-includes/js/wp-embed.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?onload=contact_form_7_recaptcha_callback&#038;render=explicit&#038;ver=1.0.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var contact_form_7_recaptcha_data = {"sitekey":"6LeMowgAAAAAAIwe3AqkBZn9cJkFl98avteo_Tgu"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navarrepress.com/wp-content/plugins/contact-form-7-recaptcha/script.js?ver=1.0.0'></script>
<script type="text/javascript">
			var bwpRecaptchaCallback = function() {
				// render all collected recaptcha instances
			};
		</script>
<script src="https://www.google.com/recaptcha/api.js?onload=bwpRecaptchaCallback&#038;render=explicit" async defer></script>
</div> 
</div>
</div>
</section>
</body>
</html>