<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7"  xmlns:fb="https://www.facebook.com/2008/fbml"  xmlns:og="http://ogp.me/ns#" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8"  xmlns:fb="https://www.facebook.com/2008/fbml"  xmlns:og="http://ogp.me/ns#" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html  xmlns:fb="https://www.facebook.com/2008/fbml"  xmlns:og="http://ogp.me/ns#" lang="en-US">
<!--<![endif]-->
<head>

<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=0.9, minimum-scale=0.9">

<meta name="description" content="Local news for Navarre, Navarre Beach and Gulf Breeze area in Northwest Florida panhandle." />



<title>Five Things to Know in Florida for Dec. 20 | Navarre Press</title>

<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://navarrepress.com/xmlrpc.php" />

<link rel="stylesheet" type="text/css" media="print" href="http://navarrepress.com/wp-content/themes/Stylebook-NEW/print.css" />

<script type='text/javascript'>

var googletag = googletag || {};

googletag.cmd = googletag.cmd || [];

(function() {

var gads = document.createElement('script');

gads.async = true;

gads.type = 'text/javascript';

var useSSL = 'https:' == document.location.protocol;

gads.src = (useSSL ? 'https:' : 'http:') + 

'//www.googletagservices.com/tag/js/gpt.js';

var node = document.getElementsByTagName('script')[0];

node.parentNode.insertBefore(gads, node);

})();

</script>



<script type='text/javascript'>

googletag.cmd.push(function() {

googletag.defineSlot('/1371603/125x125_Box_Frontpage', [125, 125], 'div-gpt-ad-1415632547591-0').addService(googletag.pubads());

googletag.defineSlot('/1371603/BoxAd-Front', [300, 250], 'div-gpt-ad-1415637387971-0').addService(googletag.pubads());

googletag.defineSlot('/1371603/BoxAd-Front', [300, 250], 'div-gpt-ad-1415634730967-0').addService(googletag.pubads());

googletag.defineSlot('/1371603/BoxAd-Front', [300, 250], 'div-gpt-ad-1384382224685-0').addService(googletag.pubads());

googletag.defineSlot('/1371603/Front_Page_Image', [171, 285], 'div-gpt-ad-1384382224685-1').addService(googletag.pubads());

googletag.defineSlot('/1371603/Right_Skyscraper', [160, 600], 'div-gpt-ad-1384382224685-2').addService(googletag.pubads());

googletag.defineSlot('/1371603/Top-Banner', [728, 90], 'div-gpt-ad-1384382224685-3').addService(googletag.pubads());

googletag.pubads().enableSingleRequest();

googletag.enableServices();

});

</script>



<script type="text/javascript">

 var oa = document.createElement('script');

 oa.type = 'text/javascript'; oa.async = true;

 oa.src = '//navarrepress.api.oneall.com/socialize/library.js'

 var s = document.getElementsByTagName('script')[0];

 s.parentNode.insertBefore(oa, s)

</script>




<!-- This site is optimized with the Yoast SEO plugin v4.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://navarrepress.com/?p=59523" />
<link rel="publisher" href="https://plus.google.com/+Navarrepress1"/>
<!-- / Yoast SEO plugin. -->

<link rel="alternate" type="application/rss+xml" title="Navarre Press &raquo; Feed" href="http://navarrepress.com/?feed=rss2" />
<link rel="alternate" type="application/rss+xml" title="Navarre Press &raquo; Comments Feed" href="http://navarrepress.com/?feed=comments-rss2" />
<link rel="alternate" type="text/calendar" title="Navarre Press &raquo; iCal Feed" href="http://navarrepress.com?post_type=tribe_events&#038;ical=1" />
<link rel="alternate" type="application/rss+xml" title="Navarre Press &raquo; Five Things to Know in Florida for Dec. 20 Comments Feed" href="http://navarrepress.com/?feed=rss2&#038;p=59523" />
<meta property="og:title" content="Five Things to Know in Florida for Dec. 20"/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="http://navarrepress.com/?p=59523"/>
<meta property="og:site_name" content="Navarre Press"/>
<meta property="og:image" content="http://navarrepress.com/wp-content/uploads/2014/01/NP_5Things-300x176.jpg"/>
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/navarrepress.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.5.4"}};
			!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;if(!g||!g.fillText)return!1;switch(g.textBaseline="top",g.font="600 32px Arial",a){case"flag":return g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3;case"diversity":return g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,d=c[0]+","+c[1]+","+c[2]+","+c[3],g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e;case"simple":return g.fillText(h(55357,56835),0,0),0!==g.getImageData(16,16,1,1).data[0];case"unicode8":return g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='tp-sidebar-login-css'  href='http://navarrepress.com/wp-content/plugins/tt-sidebar-login-widget/assets/css/tt-sidebar-login.css?ver=4.5.4' type='text/css' media='all' />
<link rel='stylesheet' id='jinda-social-css'  href='http://navarrepress.com/wp-content/plugins/jinda-facebook-lightbox/public/css/jinda-social-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://navarrepress.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.6' type='text/css' media='all' />
<link rel='stylesheet' id='cntctfrm_form_style-css'  href='http://navarrepress.com/wp-content/plugins/contact-form-plugin/css/form_style.css?ver=4.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='gabfire-widget-css-css'  href='http://navarrepress.com/wp-content/plugins/gabfire-widget-pack/css/style.css?ver=4.5.4' type='text/css' media='all' />
<link rel='stylesheet' id='photocrati-image_protection-css-css'  href='http://navarrepress.com/wp-content/plugins/nextgen-gallery-plus/modules/image_protection/static/custom.css?ver=4.5.4' type='text/css' media='all' />
<link rel='stylesheet' id='wp-booklet-dark-css'  href='http://navarrepress.com/wp-content/plugins/wp-booklet/themes/booklet/dark/booklet.css?ver=4.5.4' type='text/css' media='all' />
<link rel='stylesheet' id='wp-booklet-light-css'  href='http://navarrepress.com/wp-content/plugins/wp-booklet/themes/booklet/light/booklet.css?ver=4.5.4' type='text/css' media='all' />
<link rel='stylesheet' id='event-list-css'  href='http://navarrepress.com/wp-content/plugins/event-list/includes/css/event-list.css?ver=4.5.4' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='http://navarrepress.com/wp-content/themes/Stylebook-NEW/framework/bootstrap/css/bootstrap.min.css?ver=4.5.4' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-responsive-css'  href='http://navarrepress.com/wp-content/themes/Stylebook-NEW/framework/bootstrap/css/bootstrap-responsive.min.css?ver=4.5.4' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://navarrepress.com/wp-content/themes/Stylebook-NEW/framework/font-awesome/css/font-awesome.min.css?ver=4.5.4' type='text/css' media='all' />
<link rel='stylesheet' id='gabfire-style-css'  href='http://navarrepress.com/wp-content/themes/Stylebook-NEW/style.css?ver=4.5.4' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var tribe_events_linked_posts = {"post_types":{"tribe_venue":"venue","tribe_organizer":"organizer"}};
/* ]]> */
</script>
<script type='text/javascript' src='http://navarrepress.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-content/plugins/jinda-facebook-lightbox/public/js/lib/js.cookie-2.0.3.min.js?ver=2.0.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jinda_obj = {"facebook_page_url":"https:\/\/www.facebook.com\/navarrepress","close_click_overlay":"0","show_interval":"24","popup_delay":"1000"};
/* ]]> */
</script>
<script type='text/javascript' src='http://navarrepress.com/wp-content/plugins/jinda-facebook-lightbox/public/js/jinda-social-public.js?ver=1.0.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var norightclick_args = {"rightclick":"Y","draganddrop":"Y"};
/* ]]> */
</script>
<script type='text/javascript' src='http://navarrepress.com/wp-content/plugins/image-watermark/js/no-right-click.js?ver=1.6.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var photocrati_image_protection_global = {"enabled":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='http://navarrepress.com/wp-content/plugins/nextgen-gallery-plus/modules/image_protection/static/custom.js?ver=4.5.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-content/plugins/wp-booklet/assets/js/jquery.wpbooklet.js?ver=4.5.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-content/plugins/wp-booklet/assets/js/jquery.wpbookletcarousel.js?ver=4.5.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-content/plugins/wp-booklet/assets/js/jquery.wpbooklet-image-popup.min.js?ver=4.5.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-content/plugins/wp-booklet/assets/js/jquery.wpbooklet-extended.js?ver=4.5.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-content/themes/Stylebook-NEW/inc/js/jquery.cycle2.min.js?ver=4.5.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-content/themes/Stylebook-NEW/inc/js/jquery.easing.min.js?ver=4.5.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-content/themes/Stylebook-NEW/inc/js/jquery.contentcarousel.js?ver=4.5.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-content/themes/Stylebook-NEW/framework/bootstrap/js/bootstrap.min.js?ver=4.5.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-content/themes/Stylebook-NEW/inc/js/flowplayer/flowplayer.min.js?ver=4.5.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-content/themes/Stylebook-NEW/inc/js/responsive-menu.js?ver=4.5.4'></script>
<link rel='https://api.w.org/' href='http://navarrepress.com/?rest_route=/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://navarrepress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://navarrepress.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.5.4" />
<link rel='shortlink' href='http://navarrepress.com/?p=59523' />
<link rel="alternate" type="application/json+oembed" href="http://navarrepress.com/?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=http%3A%2F%2Fnavarrepress.com%2F%3Fp%3D59523" />
<link rel="alternate" type="text/xml+oembed" href="http://navarrepress.com/?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=http%3A%2F%2Fnavarrepress.com%2F%3Fp%3D59523&#038;format=xml" />
<link rel="alternate" type="application/rss+xml" title="Navarre Press GeoRSS-Feed" href="http://navarrepress.com/wp-content/plugins/leaflet-maps-marker/leaflet-georss.php?layer=all" />
<!-- <meta name="NextGEN" version="2.1.62" /> -->

 <!-- OneAll.com / Social Login for WordPress / v5.2 -->
<script data-cfasync="false" type="text/javascript">
 (function() {
  var oa = document.createElement('script'); oa.type = 'text/javascript';
  oa.async = true; oa.src = 'http://navarrepress.api.oneall.com/socialize/library.js';
  var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(oa, s);
 })();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-6930017-1', 'navarrepress.com');
  ga('send', 'pageview');

</script>
<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["trackPageView"]);
  _paq.push(["enableLinkTracking"]);

  (function() {
    var u=(("https:" == document.location.protocol) ? "https" : "http") + "://www.sandpaperpublishing.com/analytics3/";
    _paq.push(["setTrackerUrl", u+"piwik.php"]);
    _paq.push(["setSiteId", "20"]);
    var d=document, g=d.createElement("script"), s=d.getElementsByTagName("script")[0]; g.type="text/javascript";
    g.defer=true; g.async=true; g.src=u+"piwik.js"; s.parentNode.insertBefore(g,s);
  })();
</script>
<!-- End Piwik Code -->

<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/1371603/BoxAd-Front', [300, 250], 'div-gpt-ad-1384382224685-0').addService(googletag.pubads());
googletag.defineSlot('/1371603/Front_Page_Image', [171, 285], 'div-gpt-ad-1384382224685-1').addService(googletag.pubads());
googletag.defineSlot('/1371603/Right_Skyscraper', [160, 600], 'div-gpt-ad-1384382224685-2').addService(googletag.pubads());
googletag.defineSlot('/1371603/Top-Banner', [728, 90], 'div-gpt-ad-1384382224685-3').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>
<link rel="shortcut icon" href="http://navarrepress.com/wp-content/uploads/2013/11/NP_webicon.png"/>
<!-- Custom Styling -->
<style type="text/css">
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/1371603/BoxAd-Front', [300, 250], 'div-gpt-ad-1384382224685-0').addService(googletag.pubads());
googletag.defineSlot('/1371603/Front_Page_Image', [171, 285], 'div-gpt-ad-1384382224685-1').addService(googletag.pubads());
googletag.defineSlot('/1371603/Right_Skyscraper', [160, 600], 'div-gpt-ad-1384382224685-2').addService(googletag.pubads());
googletag.defineSlot('/1371603/Top-Banner', [728, 90], 'div-gpt-ad-1384382224685-3').addService(googletag.pubads());
googletag.defineSlot('/1371603/Top-of-Homepage', [728, 90], 'div-gpt-ad-1427222959734-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script></style>
	<script type='text/javascript'>
	<!--	
	(function($){
		$.fn.jfontsize = function(opcoes) {
			var $this=$(this);
			var defaults = {
				btnMinusClasseId: '.fontSizeMinus',
				btnPlusClasseId: '.fontSizePlus',
				btnMinusMaxHits: 5,
				btnPlusMaxHits: 5,
				sizeChange: 1
			};

			if(($.isArray(opcoes))||(!opcoes)){
				opcoes = $.extend(defaults, opcoes);
			} else {
				defaults.sizeChange = opcoes;
				opcoes = defaults;
			}

			var limite=new Array();
			var fontsize_padrao=new Array();

			$(this).each(function(i){
				limite[i]=0;
				fontsize_padrao[i];
			})

			$('.fontSizeMinus, .fontSizePlus').removeAttr('href');
			$('.fontSizeMinus, .fontSizePlus').css('cursor', 'pointer');

			/* A- */
			$('.fontSizeMinus').click(function(){
				$this.each(function(i){
					if (limite[i]>(-(opcoes.btnMinusMaxHits))){
						fontsize_padrao[i]=$(this).css('font-size');
						fontsize_padrao[i]=fontsize_padrao[i].replace('px', '');
						fontsize=$(this).css('font-size');
						fontsize=parseInt(fontsize.replace('px', ''));
						fontsize=fontsize-(opcoes.sizeChange);
						fontsize_padrao[i]=fontsize_padrao[i]-(limite[i]*opcoes.sizeChange);
						limite[i]--;
						$(this).css('font-size', fontsize+'px');
					}
				})
			})

			/* A+ */
			$('.fontSizePlus').click(function(){
				$this.each(function(i){
					if (limite[i]<opcoes.btnPlusMaxHits){
						fontsize_padrao[i]=$(this).css('font-size');
						fontsize_padrao[i]=fontsize_padrao[i].replace('px', '');
						fontsize=$(this).css('font-size');
						fontsize=parseInt(fontsize.replace('px', ''));
						fontsize=fontsize+opcoes.sizeChange;
						fontsize_padrao[i]=fontsize_padrao[i]-(limite[i]*opcoes.sizeChange);
						limite[i]++;
						$(this).css('font-size', fontsize+'px');
					}
				})
			})
		};
	})(jQuery);	
	(function($) {
		$.noConflict();
		$(document).ready(function() {
			$(".children").parent("li").addClass("has-child-menu");
			$(".sub-menu").parent("li").addClass("has-child-menu");
			$(".drop").parent("li").addClass("has-child-menu");
			
			$('.fadeimage').hover(
				function() {$(this).stop().animate({ opacity: 0.5 }, 800);},
				function() {$(this).stop().animate({ opacity: 1.0 }, 800);}
			);
			
			$('.mastheadnav li ul,.mainnav li ul,.secondnav li ul').hide().removeClass('fallback');
			$('.mastheadnav > li,.mainnav > li,.secondnav > li').hover(
				function () {
					$('ul', this).stop().slideDown(250);
				},
				function () {
					$('ul', this).stop().slideUp(250);
				}
			);			
						
			$('#tabs-left').tab();
			$('#tabs > li > a').hover( function(){$(this).tab('show');});
			$("ul.tabs").tabs("div.panes > div");
			$("ul.sc_tabs").tabs("div.sc_tabs-content > div");
			
			$('.entry p').jfontsize();
			
			
				$('#bootstartCarousel').carousel({
				interval: 4000,
				pause : 'hover'
				});
							
			$('.mediagallery').contentcarousel({
				// speed for the sliding animation
				sliderSpeed     : 500,
				// easing for the sliding animation
				sliderEasing    : 'easeOutExpo',
				// speed for the item animation (open / close)
				itemSpeed       : 500,
				// easing for the item animation (open / close)
				itemEasing      : 'easeOutExpo',
				// number of items to scroll at a time
				scroll          : 1
			});	
						
			$('a[href="#top"]').click(function(){	$('html, body').animate({scrollTop:0}, 'slow');	return false; });		
			// Responsive Menu (TinyNav)
			$(".menu").tinyNav({
				active: 'current_page_item', // Set the "active" class for default menu
				label: ''
			});
			$(".tinynav").selectbox();
			$('.tooltip-link').tooltip({ placement: 'right'});

		});
	})(jQuery);
	// -->
	</script>
	
<style type="text/css" id="custom-background-css">
body.custom-background { background-image: url('http://navarrepress.com/wp-content/uploads/2013/12/MG_10013.jpg'); background-repeat: no-repeat; background-position: top center; background-attachment: fixed; }
</style>
			<!-- Easy Columns 2.1.1 by Pat Friedl http://www.patrickfriedl.com -->
			<link rel="stylesheet" href="http://navarrepress.com/wp-content/plugins/easy-columns/css/easy-columns.css" type="text/css" media="screen, projection" />
			
<!-- START - Facebook Open Graph, Google+ and Twitter Card Tags 2.0.6.1 -->
 <!-- Facebook Open Graph -->
  <meta property="og:locale" content="en_US"/>
  <meta property="og:site_name" content="Navarre Press"/>
  <meta property="og:title" content="Five Things to Know in Florida for Dec. 20 | Navarre Press"/>
  <meta property="og:url" content="http://navarrepress.com/?p=59523"/>
  <meta property="og:type" content="article"/>
  <meta property="og:description" content="FLORIDA&#039;S 29 ELECTORS CAST VOTES FOR DONALD TRUMP IN TALLAHASSEE Florida&#039;s 29 electors cast their votes for Donald Trump inside the state Senate chambers Monday as about 200 people protested outside the doors. Protesters shouted, &quot;Love trumps hate&quot; just before the vote took place, and &quot;Vote your"/>
  <meta property="og:image" content="http://navarrepress.com/wp-content/uploads/2014/01/NP_5Things.jpg"/>
  <meta property="article:published_time" content="2016-12-20T08:38:49+00:00"/>
  <meta property="article:modified_time" content="2016-12-20T08:38:49+00:00" />
  <meta property="og:updated_time" content="2016-12-20T08:38:49+00:00" />
  <meta property="article:section" content="5 things to know in Florida"/>
 <!-- Google+ / Schema.org -->
  <meta itemprop="name" content="Five Things to Know in Florida for Dec. 20 | Navarre Press"/>
  <meta itemprop="description" content="FLORIDA&#039;S 29 ELECTORS CAST VOTES FOR DONALD TRUMP IN TALLAHASSEE Florida&#039;s 29 electors cast their votes for Donald Trump inside the state Senate chambers Monday as about 200 people protested outside the doors. Protesters shouted, &quot;Love trumps hate&quot; just before the vote took place, and &quot;Vote your"/>
  <meta itemprop="image" content="http://navarrepress.com/wp-content/uploads/2014/01/NP_5Things.jpg"/>
 <!-- Twitter Cards -->
  <meta name="twitter:title" content="Five Things to Know in Florida for Dec. 20 | Navarre Press"/>
  <meta name="twitter:url" content="http://navarrepress.com/?p=59523"/>
  <meta name="twitter:description" content="FLORIDA&#039;S 29 ELECTORS CAST VOTES FOR DONALD TRUMP IN TALLAHASSEE Florida&#039;s 29 electors cast their votes for Donald Trump inside the state Senate chambers Monday as about 200 people protested outside the doors. Protesters shouted, &quot;Love trumps hate&quot; just before the vote took place, and &quot;Vote your"/>
  <meta name="twitter:image" content="http://navarrepress.com/wp-content/uploads/2014/01/NP_5Things.jpg"/>
  <meta name="twitter:card" content="summary_large_image"/>
 <!-- SEO -->
 <!-- Misc. tags -->
<!-- END - Facebook Open Graph, Google+ and Twitter Card Tags 2.0.6.1 -->

<meta data-pso-pv="1.2.1" data-pso-pt="singlePost" data-pso-th="6a5271567fbb1e994406fb645fcb2053"><style type="text/css" media="screen">body {font-size: 12px;font-family: arial;font-weight: normal;color: #555555;background: url(http://navarrepress.com/wp-content/themes/Stylebook-NEW/framework/images/patterns/none.jpg) repeat;}.sitebody p,.entry p, label,input,button,select,textarea, .posttitle.list_posttitle {font-size: 12px;font-family: arial;font-weight: normal;color: #555555;}.posttitle, .posttitle a {font-size: 20px;font-family: arial;font-weight: bold;color: #0e829f;}.posttitle a:hover {color:#12775e;}.posttitle.list_posttitle, .posttitle.list_posttitle a {font-size: 12px;font-family: arial;font-weight: bold;color: #555555;}.posttitle.list_posttitle a:hover {color:#12775e;}.post-lead h1 {font-size: 24px;font-family: arial;font-weight: bold;color: #0e829f;}.post-lead p.subtitle {font-size: 12px;font-family: arial;font-weight: normal;color: #555555;}.post-lead p.subtitle, 
								nav .mastheadnav li ul li a:hover,
								nav .mastheadnav li li.has-child-menu > a:hover,
								.social_header a:hover i,
								nav .mainnav li ul li a:hover,
								nav .mainnav li li.has-child-menu > a:hover,
								nav .secondnav li ul li a:hover,
								nav .secondnav li li.has-child-menu > a:hover,
								#respond .form-submit #submit:hover,
								.follow_us a:hover i,
								footer .about_more,footer .about_more:hover,
								footer h4 span,
								.post-lead span i{ background-color:#6db9e3;}
							
							a,
							.post-column .highlight,
							.inner-cycle .template-pager span.cycle-pager-active,
							#tab-content1 li a:hover,
							.widgetinner a{ color:#6db9e3;}
							.primarybottom_right_firstcol .nav-tabs > li.firsttab.active > a,
							.primarybottom_right_firstcol .nav-tabs > li.firsttab.active > a:hover,
							.primarybottom_right_firstcol .nav-tabs > li.firsttab.active > a:focus,
							.primarybottom_right_firstcol .nav > li.firsttab > a:hover,
							.primarybottom_right_firstcol .nav > li.firsttab > a:focus  {background:#19a585;border: 1px solid #19a585;}
							.primarybottom_right_firstcol #firsttab-content {border-top:3px solid #19a585;}
							.primarybottom_right_firstcol #firsttab-content .tab_moreentries {background:#19a585}
							.primarybottom_right_firstcol .nav-tabs > li.secondtab.active > a,
							.primarybottom_right_firstcol .nav-tabs > li.secondtab.active > a:hover,
							.primarybottom_right_firstcol .nav-tabs > li.secondtab.active > a:focus,
							.primarybottom_right_firstcol .nav > li.secondtab > a:hover,
							.primarybottom_right_firstcol .nav > li.secondtab > a:focus  {background:#bddb8c;border: 1px solid #bddb8c;}
							.primarybottom_right_firstcol #secondtab-content {border-top:3px solid #bddb8c;}
							.primarybottom_right_firstcol #secondtab-content .tab_moreentries {background:#bddb8c}
							.primarybottom_right_firstcol .nav-tabs > li.thirdtab.active > a,
							.primarybottom_right_firstcol .nav-tabs > li.thirdtab.active > a:hover,
							.primarybottom_right_firstcol .nav-tabs > li.thirdtab.active > a:focus,
							.primarybottom_right_firstcol .nav > li.thirdtab > a:hover,
							.primarybottom_right_firstcol .nav > li.thirdtab > a:focus  {background:#f9e098;border: 1px solid #f9e098;}
							.primarybottom_right_firstcol #thirdtab-content {border-top:3px solid #f9e098;}
							.primarybottom_right_firstcol #thirdtab-content .tab_moreentries {background:#f9e098}
							nav .mastheadnav li a:hover,
							.headerquote-inner .quotecaption a,
							.headerquote-inner .quotecaption a:hover
							.headerquote-inner .quotecaption{color:#0e829f;}
							nav .mainnav,
							.featured-cycle .cycle-pager a.cycle-pager-active,
							.primarybottom-left .nav-tabs > li.active > a{background-color:#0e829f}
							.primarybottom-left .nav-tabs > li.active > a{border-color:#0e829f;}</style>
<!--[if IE 7]>
  <![endif]-->

<!-- HTML5 shim, for IE6-8 support of HTML5 elements -->
<!--[if lt IE 9]>
	<script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>
<![endif]-->

<link rel='stylesheet' id='font-awesome-ie7-css'  href='http://navarrepress.com/wp-content/themes/Stylebook-NEW/framework/font-awesome/css/font-awesome-ie7.min.css?ver=4.5.4' type='text/css' media='all' />
</head>

<body class="single single-post postid-59523 single-format-standard custom-background tribe-no-js">

<div class="pagetools">
				<a class="pagetool_item tooltip-link" href="http://navarrepress.com/?p=59520" title="Prev post: Raiders gain valuable experience at shootout"><i class="icon-arrow-left"></i></a>
					<a class="pagetool_item tooltip-link" href="http://navarrepress.com/?p=59529" title="Next post: County recycles Christmas trees"><i class="icon-arrow-right"></i></a>
		
	<a class="pagetool_item tooltip-link" href="http://navarrepress.com/contact/" title="Get in touch with us"><i class="icon-envelope-alt"></i></a>	<a class="pagetool_item tooltip-link" href="http://navarrepress.com" title="Go to homepage"><i class="icon-home"></i></a>	<a class="pagetool_item tooltip-link" href="http://navarrepress.com/search/" title="Search in site..."><i class="icon-search"></i></a></div>


<div class="container">
		<div class="row">
			<div class="span12">
				<div class="sitebody">
					<header class="site-header">

						<div class="masthead">
						
							<nav class="masthead-navigation">
								<ul class="mastheadnav menu">

									<li><a href="http://navarrepress.com/?page_id=23739"><img src="http://navarrepress.com/wp-content/uploads/2014/01/SubscribeNow.gif"></a></li>

									<li><a href="http://navarrepress.fl.newsmemory.com/" target="_blank"><img src="http://navarrepress.com/wp-content/uploads/2014/01/Read_eEdition.gif"></a></li>

									<li><a href="http://navarrepress.com/advertise/?doing_wp_cron=1476979287.7243909835815429687500" target="_blank"><img src="http://navarrepress.com/wp-content/uploads/2014/08/Advertise.gif"></a></li>

									<li id="menu-item-46879" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-46879"><a href="http://navarrepress.fl.newsmemory.com/">e-Edition</a>
<ul class="sub-menu">
	<li id="menu-item-46880" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46880"><a target="_blank" href="http://navarrepress.fl.newsmemory.com/special.php?date=20160121">2016 Mind, Body and Spirit</a></li>
	<li id="menu-item-46882" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46882"><a target="_blank" href="http://navarrepress.fl.newsmemory.com/special.php?date=20161124">2016 Holiday Happenings</a></li>
	<li id="menu-item-46884" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46884"><a target="_blank" href="http://navarrepress.fl.newsmemory.com/special.php?pSetup=navarrepress_visitorsguide">2016 Visitor&#8217;s Guide</a></li>
	<li id="menu-item-58534" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58534"><a href="http://navarrepress.fl.newsmemory.com/special.php">2016 Fall Sports Guide</a></li>
	<li id="menu-item-46885" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46885"><a target="_blank" href="http://yourschoolcalendar.com">School Calendars</a></li>
	<li id="menu-item-57088" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57088"><a href="http://navarrepress.com/wp-content/uploads/2016/09/declass28pages2016.pdf">9/11 Joint Inquiry</a></li>
	<li id="menu-item-46886" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46886"><a target="_blank" href="http://navarrepress.fl.newsmemory.com/special.php?date=20140130">FREE edition: January 30, 2016</a></li>
</ul>
</li>
<li id="menu-item-32882" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32882"><a title="Fictitious Name Legal Notice" href="http://navarrepress.com/?page_id=23643">Fictitious Name</a></li>
<li id="menu-item-30804" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30804"><a title="Navarre Area Garage Sales" href="http://navarrepress.com/?page_id=30798">Garage Sales</a></li>
<li id="menu-item-43410" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-43410"><a>Tutorials</a>
<ul class="sub-menu">
	<li id="menu-item-43411" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43411"><a href="https://www.youtube.com/watch?v=j061S9Mk86A&#038;feature=youtu.be">How to Use the Navarre Press Restaurant Inspection Database</a></li>
</ul>
</li>
<li id="menu-item-30949" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-30949"><a>Photo Gallery</a>
<ul class="sub-menu">
	<li id="menu-item-30950" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30950"><a title="Photo Galleries By Issue" href="http://navarrepress.com/?page_id=30943">By Issue</a></li>
	<li id="menu-item-30951" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30951"><a title="Photo Galleries By Year/Month" href="http://navarrepress.com/?page_id=30941">By Year/Month</a></li>
	<li id="menu-item-30970" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30970"><a target="_blank" href="https://www.shutterfly.com/pro/navarrepress/2016renourishment">2016 Beach Renourishment</a></li>
	<li id="menu-item-54772" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54772"><a target="_blank" href="https://www.shutterfly.com/pro/navarrepress/NavarreHigh2016">2016 NHS Graduation</a></li>
	<li id="menu-item-54791" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54791"><a target="_blank" href="https://www.shutterfly.com/pro/navarrepress/2016raidergames">2016 Raider Games</a></li>
	<li id="menu-item-54767" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54767"><a target="_blank" href="https://www.shutterfly.com/pro/navarrepress/2016thursdayconcerts">2016 Concerts in the Park</a></li>
	<li id="menu-item-30969" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30969"><a target="_blank" href="https://www.shutterfly.com/pro/navarrepress/2016naturalizations">2016 Naturalizations</a></li>
	<li id="menu-item-30972" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30972"><a target="_blank" href="https://www.shutterfly.com/pro/navarrepress/2016regatta">2016 Juana&#8217;s Goodtime Regatta</a></li>
	<li id="menu-item-58001" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58001"><a href="http://www.shutterfly.com/pro/navarrepress/runforthereef2016">2016 Run For the Reef</a></li>
	<li id="menu-item-58490" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58490"><a href="http://www.shutterfly.com/pro/navarrepress/2016spooktacular">2016 Spooktacular</a></li>
	<li id="menu-item-34064" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34064"><a target="_blank" href="http://navarrepress.com/videos/">News Videos</a></li>
	<li id="menu-item-30973" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30973"><a target="_blank" href="http://www.shutterfly.com/pro/navarrepress/CustomOrders">Custom Orders</a></li>
</ul>
</li>
<li id="menu-item-16160" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-16160"><a href="http://navarrepress.com/?page_id=9960">Contact</a>
<ul class="sub-menu">
	<li id="menu-item-30805" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30805"><a href="http://navarrepress.com/?page_id=30794">Letter to the Editor</a></li>
	<li id="menu-item-30765" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30765"><a href="http://navarrepress.com/?page_id=30745">Distribution Locations</a></li>
</ul>
</li>
<li id="menu-item-51490" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-51490"><a href="http://emeraldcoastbride.com">Emerald Coast Bride</a></li>

								</ul>
							</nav>
							
							<div class="social_header pull-right">
																			<a href="http://www.facebook.com/navarrepress" title="Facebook" rel="nofollow">
											<i class="icon-facebook pull-left"></i>
										</a>
									
																			<a href="http://twitter.com/navarrepress" title="Twitter" rel="nofollow">
											<i class="icon-twitter pull-left"></i>
										</a>
									
																			<a href="https://plus.google.com/+Navarrepress1/posts" title="Google+" rel="nofollow">
											<i class="icon-google-plus pull-left"></i>
										</a>
									
									
																		

																		
																			<a href="http://www.youtube.com/user/npwebadmin" title="Youtube" rel="nofollow">

											<i class="icon-flickr pull-left"></i>

										</a>
									
																			<a href="http://feedburner.google.com/fb/a/mailverify?uri=navarrepress" title="Email" rel="nofollow">
											<i class="icon-envelope-alt pull-left"></i>
										</a>
																				

									<a href="http://navarrepress.com/?feed=rss2" title="Site feed" rel="nofollow">
										<i class="icon-rss pull-left"></i>
									</a>
							</div><!-- social_header-->								
							<div class="clearfix"></div>
						</div><!-- /masthead -->					
					
						<div class="header_2ndrow">
							<div class="sitelogo pull-left" style="padding:0px 0px 10px 0px;">	
																	<h1>
										<a href="http://navarrepress.com/" title="News for Navarre, Navarre Beach and Gulf Breeze">
											<img src="http://navarrepress.com/wp-content/uploads/2014/01/NP-Header1.png" alt="Navarre Press" title="Navarre Press"/>
										</a>
									</h1>
															</div><!-- .logo -->					

							<div class="pull-right headerbanner" style="margin-top:0px"><div id='div-gpt-ad-1384382224685-3' style='width:728px;height:90px'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1384382224685-3'); });
</script>
</div>
<br></div>
							<div class="clearfix"></div>
						</div>
								
						<div class="nav_date pull-left">
							<script type="text/javascript">
								<!--
								var mydate=new Date()
								var day=mydate.getDay()
								var month=mydate.getMonth()
								var daym=mydate.getDate()
								if (daym<10)
								daym="0"+daym
								var montharray=new Array("Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec")
								document.write("<span class='gabfire_day'>"+daym+"</span><span class='gabfire_month'>"+montharray[month]+"</span>")
								// -->
							</script>
						</div><!-- nav_date -->
						
						<nav class="main-navigation pull-left">
							<ul class="mainnav menu pull-right">
																
																
									<li class="megadp"><a href="http://navarrepress.com/?cat=4748" class="drop">Local</a>
											
																						
											<div class="dropdown_col align_left"><!-- Begin 3 columns container -->
											
											<div class="dropdown_inner">
												<div class="dropdown_top">
													<ul class="greybox">
															<li class="cat-item cat-item-20"><a href="http://navarrepress.com/?cat=20" >Community</a>
</li>
														<li class="feed"><a href="http://navarrepress.com/?feed=rss2&amp;cat=4748">RSS Feed</a></li>
													</ul>


													<div class="dropdown_entries">
														
															<div class="featuredpost">

																	<img src="http://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=http%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2016%2F12%2Fchristmas-trees-3.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Christmas tree sales competitive market for Navarre" title="Christmas tree sales competitive market for Navarre" />																<h2 class="posttitle">
																	<a href="http://navarrepress.com/?p=59559" rel="bookmark" title="Permalink to Christmas tree sales competitive market for Navarre" >Christmas tree sales competitive&hellip;</a>
																</h2>
																<p>
																	Tree lots packed with freshly cut evergreens have&hellip;
																</p>
															</div><!-- .featuredpost -->
														
															<div class="featuredpost">

																	<img src="http://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=http%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2016%2F12%2FWreaths.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Wreaths Across America" title="Wreaths Across America" />																<h2 class="posttitle">
																	<a href="http://navarrepress.com/?p=59543" rel="bookmark" title="Permalink to Wreaths Across America" >Wreaths Across America</a>
																</h2>
																<p>
																	Buster Hartford, the nephew of Wreaths Across America&hellip;
																</p>
															</div><!-- .featuredpost -->
														
															<div class="featuredpost lastpost">

																	<img src="http://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=http%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2014%2F12%2Fchristmas-web.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="County recycles Christmas trees" title="County recycles Christmas trees" />																<h2 class="posttitle">
																	<a href="http://navarrepress.com/?p=59529" rel="bookmark" title="Permalink to County recycles Christmas trees" >County recycles Christmas trees</a>
																</h2>
																<p>
																	After the Christmas turkey’s eaten and the gifts&hellip;
																</p>
															</div><!-- .featuredpost -->
																											</div><!-- dropdown entries -->
												</div><!-- dropdown top -->
						
												<div class="dropdown_bottom">
													<div class="dropdown_ad">
																											</div>
												</div><!-- dropdown bottom -->
											</div><!-- dropdown_wrapper -->
										</div><!-- dropdown_col -->
									</li><!-- megadropdown li -->
																
									<li class="megadp"><a href="http://navarrepress.com/?cat=24" class="drop">Business</a>
											
																						
											<div class="dropdown_col align_left"><!-- Begin 3 columns container -->
											
											<div class="dropdown_inner">
												<div class="dropdown_top">
													<ul class="greybox">
															<li class="cat-item cat-item-4761"><a href="http://navarrepress.com/?cat=4761" >Companies</a>
</li>
	<li class="cat-item cat-item-4762"><a href="http://navarrepress.com/?cat=4762" >Economy</a>
</li>
	<li class="cat-item cat-item-4763"><a href="http://navarrepress.com/?cat=4763" >Industry</a>
</li>
	<li class="cat-item cat-item-4764"><a href="http://navarrepress.com/?cat=4764" >Markets</a>
</li>
														<li class="feed"><a href="http://navarrepress.com/?feed=rss2&amp;cat=24">RSS Feed</a></li>
													</ul>


													<div class="dropdown_entries">
														
															<div class="featuredpost">

																	<img src="http://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=http%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2016%2F12%2Fchristmas-trees-3.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Christmas tree sales competitive market for Navarre" title="Christmas tree sales competitive market for Navarre" />																<h2 class="posttitle">
																	<a href="http://navarrepress.com/?p=59559" rel="bookmark" title="Permalink to Christmas tree sales competitive market for Navarre" >Christmas tree sales competitive&hellip;</a>
																</h2>
																<p>
																	Tree lots packed with freshly cut evergreens have&hellip;
																</p>
															</div><!-- .featuredpost -->
														
															<div class="featuredpost">

																	<img src="http://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=http%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2016%2F12%2Fjjs-daily-grind-1.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="J.J. Chago’s expands to two new locations" title="J.J. Chago’s expands to two new locations" />																<h2 class="posttitle">
																	<a href="http://navarrepress.com/?p=59413" rel="bookmark" title="Permalink to J.J. Chago’s expands to two new locations" >J.J. Chago’s expands to two new &hellip;</a>
																</h2>
																<p>
																	Local restaurant J.J. Chago’s is expanding, opening two&hellip;
																</p>
															</div><!-- .featuredpost -->
														
															<div class="featuredpost lastpost">

																	<img src="http://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=http%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2016%2F12%2Fshutterstock_473537575.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="National Traffic Safety Board pushes for partial autonomy in vehicles" title="National Traffic Safety Board pushes for partial autonomy in vehicles" />																<h2 class="posttitle">
																	<a href="http://navarrepress.com/?p=59289" rel="bookmark" title="Permalink to National Traffic Safety Board pushes for partial autonomy in vehicles" >National Traffic Safety Board pu&hellip;</a>
																</h2>
																<p>
																	Public opinion of fully self-driving cars, known as&hellip;
																</p>
															</div><!-- .featuredpost -->
																											</div><!-- dropdown entries -->
												</div><!-- dropdown top -->
						
												<div class="dropdown_bottom">
													<div class="dropdown_ad">
																											</div>
												</div><!-- dropdown bottom -->
											</div><!-- dropdown_wrapper -->
										</div><!-- dropdown_col -->
									</li><!-- megadropdown li -->
																
									<li class="megadp"><a href="http://navarrepress.com/?cat=210" class="drop">Sports</a>
											
																						
											<div class="dropdown_col align_left"><!-- Begin 3 columns container -->
											
											<div class="dropdown_inner">
												<div class="dropdown_top">
													<ul class="greybox">
															<li class="cat-item cat-item-4781"><a href="http://navarrepress.com/?cat=4781" >Baseball</a>
</li>
	<li class="cat-item cat-item-4782"><a href="http://navarrepress.com/?cat=4782" >Basketball</a>
</li>
	<li class="cat-item cat-item-143"><a href="http://navarrepress.com/?cat=143" >Football</a>
</li>
	<li class="cat-item cat-item-682"><a href="http://navarrepress.com/?cat=682" >Golf</a>
</li>
	<li class="cat-item cat-item-4776"><a href="http://navarrepress.com/?cat=4776" >Soccer</a>
</li>
	<li class="cat-item cat-item-7933"><a href="http://navarrepress.com/?cat=7933" >Softball</a>
</li>
	<li class="cat-item cat-item-5229"><a href="http://navarrepress.com/?cat=5229" >Swimming</a>
</li>
	<li class="cat-item cat-item-7489"><a href="http://navarrepress.com/?cat=7489" >Volleyball</a>
</li>
	<li class="cat-item cat-item-5248"><a href="http://navarrepress.com/?cat=5248" >Weight Lifting</a>
</li>
														<li class="feed"><a href="http://navarrepress.com/?feed=rss2&amp;cat=210">RSS Feed</a></li>
													</ul>


													<div class="dropdown_entries">
														
															<div class="featuredpost">

																	<img src="http://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=http%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2016%2F12%2FHoops-1.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Raiders gain valuable experience at shootout" title="Raiders gain valuable experience at shootout" />																<h2 class="posttitle">
																	<a href="http://navarrepress.com/?p=59520" rel="bookmark" title="Permalink to Raiders gain valuable experience at shootout" >Raiders gain valuable experience&hellip;</a>
																</h2>
																<p>
																	Taf Bentley would have loved to see his&hellip;
																</p>
															</div><!-- .featuredpost -->
														
															<div class="featuredpost">

																	<img src="http://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=http%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2016%2F12%2FDemetrius.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Brown elevates his game to another level for Hawks" title="Brown elevates his game to another level for Hawks" />																<h2 class="posttitle">
																	<a href="http://navarrepress.com/?p=59510" rel="bookmark" title="Permalink to Brown elevates his game to another level for Hawks" >Brown elevates his game to anoth&hellip;</a>
																</h2>
																<p>
																	Demetrius Brown possessed added drive and determination heading&hellip;
																</p>
															</div><!-- .featuredpost -->
														
															<div class="featuredpost lastpost">

																	<img src="http://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=http%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2016%2F12%2FSoccer2.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Raiders roll to district win over Patriots" title="Raiders roll to district win over Patriots" />																<h2 class="posttitle">
																	<a href="http://navarrepress.com/?p=59508" rel="bookmark" title="Permalink to Raiders roll to district win over Patriots" >Raiders roll to district win ove&hellip;</a>
																</h2>
																<p>
																	Navarre’s boys soccer team started off slow against&hellip;
																</p>
															</div><!-- .featuredpost -->
																											</div><!-- dropdown entries -->
												</div><!-- dropdown top -->
						
												<div class="dropdown_bottom">
													<div class="dropdown_ad">
																											</div>
												</div><!-- dropdown bottom -->
											</div><!-- dropdown_wrapper -->
										</div><!-- dropdown_col -->
									</li><!-- megadropdown li -->
																
									<li class="megadp"><a href="http://navarrepress.com/?cat=4607" class="drop">Education</a>
											
																						
											<div class="dropdown_col align_left"><!-- Begin 3 columns container -->
											
											<div class="dropdown_inner">
												<div class="dropdown_top">
													<ul class="greybox">
															<li class="cat-item cat-item-4783"><a href="http://navarrepress.com/?cat=4783" >College</a>
</li>
	<li class="cat-item cat-item-4786"><a href="http://navarrepress.com/?cat=4786" >Elementary</a>
</li>
	<li class="cat-item cat-item-4784"><a href="http://navarrepress.com/?cat=4784" >High School</a>
</li>
	<li class="cat-item cat-item-7842"><a href="http://navarrepress.com/?cat=7842" >Intermediate</a>
</li>
	<li class="cat-item cat-item-4785"><a href="http://navarrepress.com/?cat=4785" >Middle School</a>
</li>
														<li class="feed"><a href="http://navarrepress.com/?feed=rss2&amp;cat=4607">RSS Feed</a></li>
													</ul>


													<div class="dropdown_entries">
														
															<div class="featuredpost">

																	<img src="http://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=http%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2016%2F12%2FPearlHarbor4.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Navarre High School NJROTC commemorates anniversary of Pearl Harbor" title="Navarre High School NJROTC commemorates anniversary of Pearl Harbor" />																<h2 class="posttitle">
																	<a href="http://navarrepress.com/?p=59472" rel="bookmark" title="Permalink to Navarre High School NJROTC commemorates anniversary of Pearl Harbor" >Navarre High School NJROTC comme&hellip;</a>
																</h2>
																<p>
																	On a cool, sun-splashed Wednesday morning, with miniature&hellip;
																</p>
															</div><!-- .featuredpost -->
														
															<div class="featuredpost">

																	<img src="http://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=http%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2016%2F12%2F12-15-sci-fair-grand-winners.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Holley-Navarre students to compete in regional science fair" title="Holley-Navarre students to compete in regional science fair" />																<h2 class="posttitle">
																	<a href="http://navarrepress.com/?p=59437" rel="bookmark" title="Permalink to Holley-Navarre students to compete in regional science fair" >Holley-Navarre students to compe&hellip;</a>
																</h2>
																<p>
																	Two Holley-Navarre Middle School students are headed to&hellip;
																</p>
															</div><!-- .featuredpost -->
														
															<div class="featuredpost lastpost">

																	<img src="http://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=http%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2016%2F12%2F12-15-raneys-class4.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Raney loves her students’ sense of wonder" title="Raney loves her students’ sense of wonder" />																<h2 class="posttitle">
																	<a href="http://navarrepress.com/?p=59432" rel="bookmark" title="Permalink to Raney loves her students’ sense of wonder" >Raney loves her students’ sense &hellip;</a>
																</h2>
																<p>
																	When Holley-Navarre Primary School teacher Jennifer Raney was&hellip;
																</p>
															</div><!-- .featuredpost -->
																											</div><!-- dropdown entries -->
												</div><!-- dropdown top -->
						
												<div class="dropdown_bottom">
													<div class="dropdown_ad">
																											</div>
												</div><!-- dropdown bottom -->
											</div><!-- dropdown_wrapper -->
										</div><!-- dropdown_col -->
									</li><!-- megadropdown li -->
																
									<li class="megadp"><a href="http://navarrepress.com/?cat=4606" class="drop">Arts/Entertainment</a>
											
																						
											<div class="dropdown_col align_right"><!-- Begin 3 columns container -->
											
											<div class="dropdown_inner">
												<div class="dropdown_top">
													<ul class="greybox">
															<li class="cat-item cat-item-4612"><a href="http://navarrepress.com/?cat=4612" >Celebrity</a>
</li>
	<li class="cat-item cat-item-4617"><a href="http://navarrepress.com/?cat=4617" >Events &amp; Festivals</a>
</li>
														<li class="feed"><a href="http://navarrepress.com/?feed=rss2&amp;cat=4606">RSS Feed</a></li>
													</ul>


													<div class="dropdown_entries">
														
															<div class="featuredpost">

																	<img src="http://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=http%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2016%2F12%2Flast-years-plunge-1.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Navarre is freezing for a cause" title="Navarre is freezing for a cause" />																<h2 class="posttitle">
																	<a href="http://navarrepress.com/?p=59574" rel="bookmark" title="Permalink to Navarre is freezing for a cause" >Navarre is freezing for a cause</a>
																</h2>
																<p>
																	The tradition of facing frigid water on the&hellip;
																</p>
															</div><!-- .featuredpost -->
														
															<div class="featuredpost">

																	<img src="http://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=http%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2014%2F12%2FSanta-on-Firetruck.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Holiday fun is in full swing this weekend" title="Holiday fun is in full swing this weekend" />																<h2 class="posttitle">
																	<a href="http://navarrepress.com/?p=59195" rel="bookmark" title="Permalink to Holiday fun is in full swing this weekend" >Holiday fun is in full swing thi&hellip;</a>
																</h2>
																<p>
																	Navarre will be feeling the holiday spirit Saturday,&hellip;
																</p>
															</div><!-- .featuredpost -->
														
															<div class="featuredpost lastpost">

																	<img src="http://navarrepress.com/wp-content/themes/Stylebook-NEW/timthumb.php?src=http%3A%2F%2Fnavarrepress.com%2Fwp-content%2Fuploads%2F2016%2F02%2FNavarre-Chamber.jpg&amp;q=90&amp;w=68&amp;h=65&amp;zc=1" class="alignleft" alt="Navarre Chamber highlights local business with shopping scavenger hunt" title="Navarre Chamber highlights local business with shopping scavenger hunt" />																<h2 class="posttitle">
																	<a href="http://navarrepress.com/?p=58693" rel="bookmark" title="Permalink to Navarre Chamber highlights local business with shopping scavenger hunt" >Navarre Chamber highlights local&hellip;</a>
																</h2>
																<p>
																	The Navarre Beach Area Chamber of Commerce will&hellip;
																</p>
															</div><!-- .featuredpost -->
																											</div><!-- dropdown entries -->
												</div><!-- dropdown top -->
						
												<div class="dropdown_bottom">
													<div class="dropdown_ad">
																											</div>
												</div><!-- dropdown bottom -->
											</div><!-- dropdown_wrapper -->
										</div><!-- dropdown_col -->
									</li><!-- megadropdown li -->
								<li id="menu-item-41055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41055"><a href="http://navarrepress.com/?cat=8360">REAL ESTATE</a></li>
<li id="menu-item-47200" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47200"><a href="http://navarrepress.fl.newsmemory.com/special.php?date=20150820">Sample Edition</a></li>
					

							</ul>
						</nav>

						<nav class="second-navigation menu pull-left">
							<ul class="secondnav pull-right">
								<li id="menu-item-31838" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31838"><a href="http://navarrepress.com/?cat=5399">State</a></li>
<li id="menu-item-16151" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16151"><a href="http://navarrepress.com/?cat=4751">Politics</a></li>
<li id="menu-item-30860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30860"><a href="http://navarrepress.com/?cat=26">Health</a></li>
<li id="menu-item-30872" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-30872"><a title="Lifestyle and Leisure" href="http://navarrepress.com/?cat=4610">Lifestyle</a>
<ul class="sub-menu">
	<li id="menu-item-16152" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16152"><a href="http://navarrepress.com/?cat=4752">Religion</a></li>
</ul>
</li>
<li id="menu-item-16153" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16153"><a title="Science and Environment" href="http://navarrepress.com/?cat=4753">Science</a></li>
<li id="menu-item-32394" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32394"><a href="http://navarrepress.com/?cat=5452">Technology</a></li>
<li id="menu-item-34063" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-34063"><a href="http://navarrepress.com/videos/">News Videos</a>
<ul class="sub-menu">
	<li id="menu-item-49159" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49159"><a href="http://navarrepress.com/?page_id=49013">Slideshows</a></li>
</ul>
</li>
<li id="menu-item-30853" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-30853"><a target="_blank" href="http://navarrepress.fl.newsmemory.com/">e-Edition</a>
<ul class="sub-menu">
	<li id="menu-item-42878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42878"><a href="http://navarrepress.fl.newsmemory.com/special.php?date=20160121">2016 Mind, Body and Spirit</a></li>
	<li id="menu-item-41816" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41816"><a target="_blank" href="http://navarrepress.com/pdf/2015-Special-Sections-Calendar.pdf">2015 Special Sections Calendar</a></li>
	<li id="menu-item-41755" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41755"><a href="http://navarrepress.fl.newsmemory.com/special.php?date=20151126">2015 Holiday Happenings</a></li>
	<li id="menu-item-40355" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40355"><a target="_blank" href="http://navarrepress.fl.newsmemory.com/special.php?date=20141016">2014 Homebuyer&#8217;s Guide</a></li>
	<li id="menu-item-36486" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36486"><a target="_blank" href="http://navarrepress.fl.newsmemory.com/special.php?pSetup=navarrepress_visitorsguide">2015 Visitor&#8217;s Guide</a></li>
	<li id="menu-item-30964" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30964"><a target="_blank" href="http://yourschoolcalendar.com">School Calendars</a></li>
	<li id="menu-item-30962" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30962"><a target="_blank" href="http://navarrepress.fl.newsmemory.com/special.php?date=20140130">FREE edition: January 30th</a></li>
	<li id="menu-item-30850" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30850"><a target="_blank" href="/loveagram.html">Place a Love-A-Gram!</a></li>
</ul>
</li>
<li id="menu-item-36177" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36177"><a href="http://navarrepress.com/?post_type=tribe_events">Upcoming Events</a></li>
							</ul>
						</nav>
						<div class="clearfix"></div>
						
						<section id="bootstartCarousel" class="carousel slide">
							  <div class="carousel-inner">
							  
								  
							  
								<div class="item active">
									<h2><a href="http://navarrepress.com/?p=59574" rel="bookmark" title="Permalink to Navarre is freezing for a cause" >Navarre is freezing for a cause</a></h2>
								</div>
								
								  
							  
								<div class="item ">
									<h2><a href="http://navarrepress.com/?p=59537" rel="bookmark" title="Permalink to NOTICE OF PUBLIC SALE OF PERSONAL PROPERTY | Legal #2989" >NOTICE OF PUBLIC SALE OF PERSONAL PROPERTY | Legal #2989</a></h2>
								</div>
								
								  
							  
								<div class="item ">
									<h2><a href="http://navarrepress.com/?p=59535" rel="bookmark" title="Permalink to NOTICE OF PUBLIC HEARING | Public Notice #2065" >NOTICE OF PUBLIC HEARING | Public Notice #2065</a></h2>
								</div>
								
								  
							  
								<div class="item ">
									<h2><a href="http://navarrepress.com/?p=59559" rel="bookmark" title="Permalink to Christmas tree sales competitive market for Navarre" >Christmas tree sales competitive market for Navarre</a></h2>
								</div>
								
								  
							  
								<div class="item ">
									<h2><a href="http://navarrepress.com/?p=59555" rel="bookmark" title="Permalink to Hall retires as Santa Rosa’s longest serving sheriff" >Hall retires as Santa Rosa’s longest serving sheriff</a></h2>
								</div>
								
								  
							  
								<div class="item ">
									<h2><a href="http://navarrepress.com/?p=59543" rel="bookmark" title="Permalink to Wreaths Across America" >Wreaths Across America</a></h2>
								</div>
								
								  
							  
								<div class="item ">
									<h2><a href="http://navarrepress.com/?p=59531" rel="bookmark" title="Permalink to Five Things to Know in Florida for Dec. 21" >Five Things to Know in Florida for Dec. 21</a></h2>
								</div>
								
															  </div>
							  <a class="left carousel-control" href="#bootstartCarousel" data-slide="prev">&lsaquo;</a>
							  <a class="right carousel-control" href="#bootstartCarousel" data-slide="next">&rsaquo;</a>
						</section><!-- /.carousel -->
						<div class="clearfix"></div>
					</header><!-- header -->
<div class="post-container">
			
		<!-- Post-Lead -->
		<section class="post-lead">
			<h1 class="post-title">Five Things to Know in Florida for Dec. 20</h1>
			<p class="single_postmeta">
				<span>By <a href="http://navarrepress.com/?author=13">AP News</a> on December 20, 2016</span>
				<span>
					<a rel="nofollow" href="#" id="increase-font" class="fontsize-button fontSizeMinus" title="Decrease font size"><i class="icon-minus-sign"></i></a>
					<a rel="nofollow" href="#" id="decrease-font" class="fontsize-button fontSizePlus" title="Increase font size"><i class="icon-plus-sign"></i></a>
					<a rel="nofollow" href="javascript:window.print()" class="print-this-page" title="Print this post"><i class="icon-print"></i></a>
					<a class="email-this-page" href="mailto:?subject=Navarre%20Press%20%3A%20Five%20Things%20to%20Know%20in%20Florida%20for%20Dec.%2020&amp;body=I%20recommend%20this%20page%3A%20Five%20Things%20to%20Know%20in%20Florida%20for%20Dec.%2020.%0AYou%20can%20read%20it%20on%3A%20http%3A%2F%2Fnavarrepress.com%2F%3Fp%3D59523" title="Send by email : Five Things to Know in Florida for Dec. 20"><i class="icon-envelope-alt"></i></a>				</span>
			</p>
			
										
		</section>

		<section class="postbody-wrapper postlayout-default">

		
	<div class="post-column pull-left">
		<article class="entry post-59523 post type-post status-publish format-standard has-post-thumbnail hentry category-5-things-to-know-in-florida tag-daily-news tag-december-20 tag-five-things-to-know-in-florida tag-florida tag-florida-fish-and-wildlife-conservation-commission tag-florida-panthers tag-gulf-coast tag-lee-county tag-lenny-pozner tag-loxahatchee tag-lucy-richards tag-michael-spivack tag-noah-pozner tag-peter-kubeck tag-phytoplankton tag-pinellas-county tag-president-elect-donald-trump tag-red-tide tag-rep-joe-gruters tag-sandy-hook-school tag-sarasota-county tag-secretary-of-state-ken-detzner tag-stories tag-topics tag-tuesday tag-upcoming-events tag-vincent-viola last_archivepost">		
				<p>FLORIDA&#8217;S 29 ELECTORS CAST VOTES FOR DONALD TRUMP IN TALLAHASSEE</p>
<p>Florida&#8217;s 29 electors cast their votes for Donald Trump inside the state Senate chambers Monday as about 200 people protested outside the doors. Protesters shouted, &#8220;Love trumps hate&#8221; just before the vote took place, and &#8220;Vote your conscience&#8221; as the electors filled out their ballots. Secretary of State Ken Detzner oversaw the ceremony.Before the vote, state Rep. Joe Gruters said there was no chance he and the other 28 electors would vote at odds with the statewide vote in November.</p>
<p>PRESIDENT-ELECT TRUMP PICKS BILLIONAIRE FLORIDA HOCKEY TEAM OWNER FOR ARMY SECRETARY</p>
<p>Billionaire Florida hockey team owner Vincent Viola is known more for his business success and sports deals than his military acumen. But the 1977 West Point graduate, President-elect Donald Trump&#8217;s choice for Army secretary, has maintained his service ties since leaving active duty. While he has steadily built a financial empire — listed 374th on Forbes Magazine&#8217;s top 400 with a net worth of $1.8 billion — he also has poured money and time into the military academy. Viola was a key donor for the creation of West Point&#8217;s Combating Terrorism Center and has supported cadet programs. And as owner of the National Hockey League&#8217;s Florida Panthers, he has sent the team to West Point for training, and there are several West Point graduates and military veterans working in the front office.</p>
<p>WOMAN ACCUSED OF THREATENING PARENT OF BOY KILLED IN SCHOOL SHOOTING PLEADS GUILTY TO THREATS</p>
<p>A Florida woman accused of threatening the parent of a boy killed in the Sandy Hook school shooting because she thought it was a hoax pleaded not guilty Monday and was barred from visiting websites that promote such false conspiracy theories. Lucy Richards, 57, entered her plea in Fort Lauderdale federal court after a public defender was appointed to represent her. The lawyer, Michael Spivack, declined to comment after the hearing. Richards was arrested Dec. 7 in Tampa on four felony counts of transmitting threats to Lenny Pozner, father of 6-year-old Noah Pozner who died in the 2012 mass shooting in Newtown, Connecticut.</p>
<p>MAN KILLED WHEN FRONT LOADER VEERS INTO CANAL</p>
<p>A man was killed after the construction machine he was operating accidentally plunged into a canal in Palm Beach County. The Palm Beach Sheriff&#8217;s office says 48-year-old Peter Kubeck died after he was taken to Palms West Hospital, but the cause of death wasn&#8217;t clear pending an autopsy report. Officials say the Palm Springs man was driving a front-end loader when it veered off the road and slid into a canal in Loxahatchee, Fla.</p>
<p>RED TIDE AFFECTS SEVERAL COUNTIES ON FLORIDA&#8217;S WEST COAST</p>
<p>Red tide is once again continuing its reign over some Gulf Coast beaches since September. The Florida Fish and Wildlife Conservation Commission&#8217;s red tide status report, eight water samples collected from Manatee showed very low to high concentrations of red tide. Similar readings were found in 20 samples from Sarasota County. Red tide has been detected from Pinellas County to Lee County. It happens when a certain kind of phytoplankton gathers in high concentrations, giving off toxins that are harmful to wildlife and humans.</p>
<p>&nbsp;</p>
<section id="gab_contact_widget-5" class="widget gab_contact_widget"><div class="widgetinner"><h3 class="widgettitle">Contact Us</h3>
<div class='gab_contact_logocont'><img src='http://navarrepress.com/wp-content/uploads/2013/11/aplogo.png' class='aligncenter' alt='Navarre Press' /></div><address><p>7502 Harvest Village Ct.<br />
Navarre FL 32566</p>
<a href='mailto:info@navarrepress.com'>info@navarrepress.com</a><br />850-939-8040</address><div class='clear'></div></div></section>
<section id="text-23" class="widget widget_text"><div class="widgetinner"><h3 class="widgettitle">Social Connections</h3>
			<div class="textwidget"><!-- The plugin will be embedded into this div //-->
<div id="oa_social_login_container"></div>

<script type="text/javascript">
 var _oneall = _oneall || [];
 _oneall.push(['social_login', 'set_callback_uri', window.location.href]);
 _oneall.push(['social_login', 'set_providers', ['facebook', 'google', 'instagram', 'linkedin', 'twitter', 'vimeo', 'windowslive', 'wordpress', 'yahoo', 'youtube']]);
 _oneall.push(['social_login', 'do_render_ui', 'oa_social_login_container']);
</script></div>
		</div></section>
<section id="text-15" class="widget widget_text"><div class="widgetinner"><h3 class="widgettitle">Sign Up for Our Newsletter</h3>
			<div class="textwidget"><div role="form" class="wpcf7" id="wpcf7-f32884-p59523-o1" lang="en-US" dir="ltr">
<div class="screen-reader-response"></div>
<form action="/?p=59523#wpcf7-f32884-p59523-o1" method="post" class="wpcf7-form" novalidate="novalidate">
<div style="display: none;">
<input type="hidden" name="_wpcf7" value="32884" />
<input type="hidden" name="_wpcf7_version" value="4.6" />
<input type="hidden" name="_wpcf7_locale" value="en_US" />
<input type="hidden" name="_wpcf7_unit_tag" value="wpcf7-f32884-p59523-o1" />
<input type="hidden" name="_wpnonce" value="4d9a20bb95" />
</div>
<p>Your Name<br />
    <span class="wpcf7-form-control-wrap FirstName"><input type="text" name="FirstName" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-validates-as-required" aria-required="true" aria-invalid="false" placeholder="First" /></span> <span class="wpcf7-form-control-wrap LastName"><input type="text" name="LastName" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-validates-as-required" aria-required="true" aria-invalid="false" placeholder="Last" /></span></p>
<p>Your Email<br />
    <span class="wpcf7-form-control-wrap your-email"><input type="email" name="your-email" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-email wpcf7-validates-as-required wpcf7-validates-as-email" aria-required="true" aria-invalid="false" /></span> </p>
<p><span class="wpcf7-form-control-wrap ctct-406"><span class="wpcf7-form-control wpcf7-ctct"><div><input type="hidden" value="2139240580" name="ctct-406[]" />
</div></span></span> </p>
<p><input type="hidden" name="_wpcf7_captcha_challenge_captcha-596" value="2581489072" /><img class="wpcf7-form-control wpcf7-captchac wpcf7-captcha-captcha-596" width="72" height="24" alt="captcha" src="http://navarrepress.com/wp-content/uploads/wpcf7_captcha/2581489072.png" /><br />
Enter the code from above.<br />
<span class="wpcf7-form-control-wrap captcha-596"><input type="text" name="captcha-596" value="" size="40" class="wpcf7-form-control wpcf7-captchar" autocomplete="off" aria-invalid="false" /></span></p>
<p><input type="submit" value="Sign Up" class="wpcf7-form-control wpcf7-submit" /></p>
<div class="wpcf7-response-output wpcf7-display-none"></div></form></div></div>
		</div></section>
<section id="event_list_widget-2" class="widget widget_event_list_widget"><div class="widgetinner"><h3 class="widgettitle">Upcoming events</h3>

				<div class="event-list"><p>no event</p>
				</div><div style="clear:both"><a title="show event-list page" href="http://navarrepress.com/events-navarre-fl/">show event-list page</a></div></div></section>
<section id="gabfire_search_widget-2" class="widget gabfire_search_widget"><div class="widgetinner"><h3 class="widgettitle">Search in Site</h3>
					<form class="gabfire_search_style1" action="http://navarrepress.com/">
						<fieldset style="background:#efefef;border:1px solid #eee;">
							<input type="text" style="width:80%;background:#efefef" class="gab_search_text" name="s" value="Search..." onfocus="if (this.value == 'Search...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search...';}" />
							<input type="submit" class="submit_style1" alt="Search..." />
							<div class="clearfix"></div>
						</fieldset>
					</form>				
				<div class='clear'></div></div></section>
				
				
<div id="comments">
	
	
	
			<p>
			You must be logged in to post a comment 
			<a href="http://navarrepress.com/wp-login.php?redirect_to=http%3A%2F%2Fnavarrepress.com%2F%3Fp%3D59523">
				Login			</a>
		</p>
	
</div><!-- #comments -->		</article>
	</div><!-- post column -->
		
	<aside id="sidebar" class="sidebar pull-right">
			<div class="sidebarbanner">
		<!-- BoxAd-Front -->
<div id='div-gpt-ad-1415637387971-0' style='width:300px;height:250px'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1415637387971-0'); });
</script>
</div>	</div>
		
						
		<section id="recent-posts-2" class="widget widget_recent_entries"><div class="widgetinner">		<h3 class="widgettitle">Recent Posts</h3>
		<ul>
					<li>
				<a href="http://navarrepress.com/?p=59574">Navarre is freezing for a cause</a>
						</li>
					<li>
				<a href="http://navarrepress.com/?p=59537">NOTICE OF PUBLIC SALE OF PERSONAL PROPERTY | Legal #2989</a>
						</li>
					<li>
				<a href="http://navarrepress.com/?p=59535">NOTICE OF PUBLIC HEARING | Public Notice #2065</a>
						</li>
					<li>
				<a href="http://navarrepress.com/?p=59559">Christmas tree sales competitive market for Navarre</a>
						</li>
					<li>
				<a href="http://navarrepress.com/?p=59555">Hall retires as Santa Rosa’s longest serving sheriff</a>
						</li>
				</ul>
		</div></section>
		<section id="text-24" class="widget widget_text"><div class="widgetinner"><h3 class="widgettitle">Social Connections</h3>
			<div class="textwidget"><!-- The plugin will be embedded into this div //-->
<div id="oa_social_login_container"></div>

<script type="text/javascript">
 var _oneall = _oneall || [];
 _oneall.push(['social_login', 'set_callback_uri', window.location.href]);
 _oneall.push(['social_login', 'set_providers', ['facebook', 'google', 'instagram', 'linkedin', 'twitter', 'vimeo', 'windowslive', 'wordpress', 'yahoo', 'youtube']]);
 _oneall.push(['social_login', 'do_render_ui', 'oa_social_login_container']);
</script></div>
		</div></section>

	<div class="sidebarbanner bottomad">
		<!-- Publix -->

<A HREF="https://ad.doubleclick.net/ddm/jump/N46002.2543105NAVARREPRESS/B10538150.140663293;sz=300x250;ord=[timestamp]?">

<IMG SRC="https://ad.doubleclick.net/ddm/ad/N46002.2543105NAVARREPRESS/B10538150.140663293;sz=300x250;ord=[timestamp];dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?" BORDER="0" WIDTH="300" HEIGHT="250" ALT="Advertisement"></A>	</div>
	</aside>
	<div class="clearfix"></div>
</section><!-- postlayout-default -->
	</div>
	
			</div><!-- Sitebody -->
		</div> <!-- span12 -->
	</div><!-- .row -->
</div><!-- .container -->

	<section class="container-fluid follow_us">
		<div class="container">
			<div class="row">
				<div class="span2 first-followus-div">
											<a href="http://www.facebook.com/navarrepress" rel="nofollow">
							<i class="icon-facebook icon-2x pull-left"></i>
							<span class="follow_us_linktitle">Facebook</span>
							<span class="follow_us_linkdesc">Friend Us</span>
						</a>
									</div>
				<div class="span2">
											<a href="http://twitter.com/navarrepress" rel="nofollow">
							<i class="icon-twitter icon-2x pull-left"></i>
							<span class="follow_us_linktitle">Twitter</span>
							<span class="follow_us_linkdesc">Follow Us</span>
						</a>
									</div>
				<div class="span2 third-followus-div">
											<a href="https://plus.google.com/+Navarrepress1/posts" rel="nofollow">
							<i class="icon-google-plus icon-2x pull-left"></i>
							<span class="follow_us_linktitle">Google+</span>
							<span class="follow_us_linkdesc">Circle Us</span>
						</a>
									</div>
				<div class="span2 text-align-right">
									</div>
				<div class="span2 text-align-right">
									</div>
				<div class="span2 text-align-right last-followus-div">
					<a href="http://navarrepress.com/?feed=rss2" rel="nofollow">
						<i class="icon-rss icon-2x pull-right"></i>
						<span class="follow_us_linktitle">RSS</span>
						<span class="follow_us_linkdesc">Site Feed</span>
					</a>
				</div>
				<div class="clearfix"></div>
			</div><!-- /row --> 
		</div><!-- /container --> 
	</section><!-- /follow_us -->
	
<footer class="container-fluid footer">
	<div class="container">

		<div class="row">
			<div class="span4">
				<section id="nav_menu-4" class="widget widget_nav_menu"><div class="widgetinner"><div class="menu-footer-menu-2-container"><ul id="menu-footer-menu-2" class="menu"><li id="menu-item-33437" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33437"><a target="_blank" href="http://navarrepress.com/wp-content/uploads/2016/08/2016-Navarre-Press-Adv-Brochure-1.pdf">Advertising</a>
<ul class="sub-menu">
	<li id="menu-item-33436" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33436"><a target="_blank" href="http://navarrepress.com/advertise/billboards/">Billboard</a></li>
	<li id="menu-item-33438" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33438"><a target="_blank" href="http://navarrepress.com/advertise/healthy-living/">Healthy Living</a></li>
	<li id="menu-item-33439" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33439"><a target="_blank" href="http://navarrepress.com/advertise/neighborhood/">Neighborhood</a></li>
	<li id="menu-item-33440" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33440"><a target="_blank" href="http://navarrepress.com/advertise/outdoors/">Outdoors</a></li>
	<li id="menu-item-33442" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33442"><a target="_blank" href="http://navarrepress.com/advertise/pets/">Pets</a></li>
	<li id="menu-item-54241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54241"><a href="http://navarrepress.com/wp-content/uploads/2016/05/voters_guide_2016-4.pdf">Voter&#8217;s Guide</a></li>
</ul>
</li>
<li id="menu-item-36332" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36332"><a href="http://navarrepress.com/?cat=4789">Legal Notices</a></li>
<li id="menu-item-33444" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33444"><a href="http://navarrepress.com/?page_id=30745">Distribution Locations</a></li>
<li id="menu-item-33445" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33445"><a href="http://navarrepress.com/?page_id=30794">Letter to the Editor</a></li>
<li id="menu-item-33447" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33447"><a href="http://navarrepress.com/?page_id=30778">Employment</a></li>
<li id="menu-item-38369" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38369"><a href="http://navarrepress.com/?page_id=38347">Weather Terms</a></li>
<li id="menu-item-33446" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33446"><a href="http://navarrepress.com/?page_id=9960">Contact</a></li>
<li id="menu-item-33448" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33448"><a href="http://navarrepress.com/?page_id=31188">Terms of Service</a></li>
<li id="menu-item-33449" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33449"><a href="http://navarrepress.com/?page_id=33155">Privacy Policy</a></li>
<li id="menu-item-33451" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33451"><a href="http://navarrepress.com/?page_id=30931">Site Map</a></li>
</ul></div></div></section>
			</div>
			
			<div class="span4">
				<section id="archives-4" class="widget widget_archive"><div class="widgetinner"><h3 class="widgettitle">Archives</h3>
		<label class="screen-reader-text" for="archives-dropdown-4">Archives</label>
		<select id="archives-dropdown-4" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='http://navarrepress.com/?m=201612'> December 2016 &nbsp;(112)</option>
	<option value='http://navarrepress.com/?m=201611'> November 2016 &nbsp;(166)</option>
	<option value='http://navarrepress.com/?m=201610'> October 2016 &nbsp;(171)</option>
	<option value='http://navarrepress.com/?m=201609'> September 2016 &nbsp;(168)</option>
	<option value='http://navarrepress.com/?m=201608'> August 2016 &nbsp;(156)</option>
	<option value='http://navarrepress.com/?m=201607'> July 2016 &nbsp;(151)</option>
	<option value='http://navarrepress.com/?m=201606'> June 2016 &nbsp;(164)</option>
	<option value='http://navarrepress.com/?m=201605'> May 2016 &nbsp;(133)</option>
	<option value='http://navarrepress.com/?m=201604'> April 2016 &nbsp;(153)</option>
	<option value='http://navarrepress.com/?m=201603'> March 2016 &nbsp;(158)</option>
	<option value='http://navarrepress.com/?m=201602'> February 2016 &nbsp;(135)</option>
	<option value='http://navarrepress.com/?m=201601'> January 2016 &nbsp;(146)</option>
	<option value='http://navarrepress.com/?m=201512'> December 2015 &nbsp;(145)</option>
	<option value='http://navarrepress.com/?m=201511'> November 2015 &nbsp;(142)</option>
	<option value='http://navarrepress.com/?m=201510'> October 2015 &nbsp;(174)</option>
	<option value='http://navarrepress.com/?m=201509'> September 2015 &nbsp;(160)</option>
	<option value='http://navarrepress.com/?m=201508'> August 2015 &nbsp;(155)</option>
	<option value='http://navarrepress.com/?m=201507'> July 2015 &nbsp;(160)</option>
	<option value='http://navarrepress.com/?m=201506'> June 2015 &nbsp;(168)</option>
	<option value='http://navarrepress.com/?m=201505'> May 2015 &nbsp;(132)</option>
	<option value='http://navarrepress.com/?m=201504'> April 2015 &nbsp;(174)</option>
	<option value='http://navarrepress.com/?m=201503'> March 2015 &nbsp;(172)</option>
	<option value='http://navarrepress.com/?m=201502'> February 2015 &nbsp;(139)</option>
	<option value='http://navarrepress.com/?m=201501'> January 2015 &nbsp;(148)</option>
	<option value='http://navarrepress.com/?m=201412'> December 2014 &nbsp;(143)</option>
	<option value='http://navarrepress.com/?m=201411'> November 2014 &nbsp;(168)</option>
	<option value='http://navarrepress.com/?m=201410'> October 2014 &nbsp;(182)</option>
	<option value='http://navarrepress.com/?m=201409'> September 2014 &nbsp;(149)</option>
	<option value='http://navarrepress.com/?m=201408'> August 2014 &nbsp;(193)</option>
	<option value='http://navarrepress.com/?m=201407'> July 2014 &nbsp;(194)</option>
	<option value='http://navarrepress.com/?m=201406'> June 2014 &nbsp;(140)</option>
	<option value='http://navarrepress.com/?m=201405'> May 2014 &nbsp;(141)</option>
	<option value='http://navarrepress.com/?m=201404'> April 2014 &nbsp;(124)</option>
	<option value='http://navarrepress.com/?m=201403'> March 2014 &nbsp;(120)</option>
	<option value='http://navarrepress.com/?m=201402'> February 2014 &nbsp;(101)</option>
	<option value='http://navarrepress.com/?m=201401'> January 2014 &nbsp;(98)</option>
	<option value='http://navarrepress.com/?m=201312'> December 2013 &nbsp;(85)</option>
	<option value='http://navarrepress.com/?m=201311'> November 2013 &nbsp;(75)</option>
	<option value='http://navarrepress.com/?m=201310'> October 2013 &nbsp;(10)</option>
	<option value='http://navarrepress.com/?m=201301'> January 2013 &nbsp;(3)</option>

		</select>
		</div></section>
<section id="gab_contact_widget-8" class="widget gab_contact_widget"><div class="widgetinner"><h3 class="widgettitle">Contact</h3>
<address><p>7502 Harvest Village Ct. Navarre, FL 32566</p>
<a href='mailto:info@navarrepress.com'>info@navarrepress.com</a><br />(850) 939 - 8040</address><div class='clear'></div></div></section>
<section id="sidebarlogin-4" class="widget widget_sidebarlogin"><div class="widgetinner"><h3 class="widgettitle">Login</h3>

		<form name="loginform" id="loginform" action="http://navarrepress.com/wp-login.php" method="post">
			
			<p class="login-username">
				<label for="user_login">Username</label>
				<input type="text" name="log" id="user_login" class="input" value="" size="20" />
			</p>
			<p class="login-password">
				<label for="user_pass">Password</label>
				<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" />
			</p>
			
			<p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" /> Remember Me</label></p>
			<p class="login-submit">
				<input type="submit" name="wp-submit" id="wp-submit" class="button-primary" value="Log In" />
				<input type="hidden" name="redirect_to" value="http://navarrepress.com" />
			</p>
			
		</form>				<p id="reglost">
					<a href="http://navarrepress.com/wp-login.php?action=lostpassword&redirect_to=http://navarrepress.com?sli=lost" rel="nofollow" title="Forgot Password">Forgot Password?</a>				</p>
				</div></section>
			</div>
			
			<div class="span4">
						<section id="recent-posts-4" class="widget widget_recent_entries"><div class="widgetinner">		<h3 class="widgettitle">Recent Posts</h3>
		<ul>
					<li>
				<a href="http://navarrepress.com/?p=59574">Navarre is freezing for a cause</a>
						</li>
					<li>
				<a href="http://navarrepress.com/?p=59537">NOTICE OF PUBLIC SALE OF PERSONAL PROPERTY | Legal #2989</a>
						</li>
					<li>
				<a href="http://navarrepress.com/?p=59535">NOTICE OF PUBLIC HEARING | Public Notice #2065</a>
						</li>
					<li>
				<a href="http://navarrepress.com/?p=59559">Christmas tree sales competitive market for Navarre</a>
						</li>
					<li>
				<a href="http://navarrepress.com/?p=59555">Hall retires as Santa Rosa’s longest serving sheriff</a>
						</li>
				</ul>
		</div></section>
		<section id="text-31" class="widget widget_text"><div class="widgetinner"><h3 class="widgettitle">Social Connections</h3>
			<div class="textwidget"><!-- The plugin will be embedded into this div //-->
<div id="oa_social_login_container"></div>

<script type="text/javascript">
 var _oneall = _oneall || [];
 _oneall.push(['social_login', 'set_callback_uri', window.location.href]);
 _oneall.push(['social_login', 'set_providers', ['facebook', 'google', 'instagram', 'linkedin', 'twitter', 'vimeo', 'windowslive', 'wordpress', 'yahoo', 'youtube']]);
 _oneall.push(['social_login', 'do_render_ui', 'oa_social_login_container']);
</script></div>
		</div></section>
			</div>
		</div>
	</div>
</footer>

<section class="container-fluid footer_meta">
	<div class="container">
		<div class="row">
			<div class="span6 footer-left-side">
									<a href="#top" title="Navarre Press"><strong>&uarr;</strong> Navarre Press</a>
							</div><!-- #site-info -->
						
			<div class="span6 footer-right-side">
				© Copyright 2016-2020 Sandpaper Publishing, Inc.				
				<a href="http://wordpress.org/" title="Semantic Personal Publishing Platform">Powered by WordPress</a> - 
				Designed by <a href="http://www.gabfirethemes.com/" title="Premium WordPress Themes">Gabfire Themes</a> &nbsp;
				<!-- ngg_resource_manager_marker --><script type='text/javascript' src='http://navarrepress.com/wp-includes/js/comment-reply.min.js?ver=4.5.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://navarrepress.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.6'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-content/plugins/gabfire-widget-pack/js/jquery.tools.min.js?ver=4.5.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://navarrepress.com/wp-includes/js/wp-embed.min.js?ver=4.5.4'></script>
		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		
		
		<div id="fb-root"></div>
		<script type='text/javascript'>
		<!--
		(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));
		// -->
		</script>
			
			<script type="text/javascript">
			var bwpRecaptchaCallback = function() {
				// render all collected recaptcha instances
			};
		</script>

		<script src="https://www.google.com/recaptcha/api.js?onload=bwpRecaptchaCallback&#038;render=explicit" async defer></script>
			</div> <!-- #footer-right-side -->
		</div>
	</div>
</section>

</body>
</html>